Metricbeat unable to import dashboards

Hello,

I have just installed 7.1.1 with security enabled. I have reconfigured the metricbeat with the credentials but when I am starting it would fail with the following errors:

https://pastebin.com/GhD3hH5a

The metricbeat.yml looks like this:

metricbeat.config.modules:
  # Glob pattern for configuration loading
  path: ${path.config}/modules.d/*.yml
  # Set to true to enable config reloading
  reload.enabled: false

  # Period on which files under path should be checked for changes
  #reload.period: 10s
setup.template.settings:
  index.number_of_shards: 1
  index.codec: best_compression
  #_source.enabled: false
tags: ["logger", "management"]
setup.dashboards.enabled: true
setup.kibana:
  host: "http://localhost:5601"
output.elasticsearch:
  hosts: ["localhost:9200"]
  username: "ingest"
  password: "somepass"
processors:
  - add_host_metadata: ~
  - add_cloud_metadata: ~
logging.level: error
logging.selectors: ["*"]
xpack.monitoring.enabled: true
xpack.monitoring.elasticsearch:
  username: "beat_system"
  password: "some beat encrypted password"
migration.6_to_7.enabled: true

Any idea what the problem could be?

  1. In kibana yml set ssl option to false as below.
    server.ssl.enabled: false

  2. restart the kibana
    systemctl restart kibana

  3. update the kibana secution in metricbeat yml, as below
    setup.kibana:
    host: "http://username:password@x.x.x.x:5601"

use kibana login username & password and kibana ip address.

  1. then run below command where metricbeat installed
    ./metricbeat.exe setup --dashboards

  2. after exporting dashboards, roll back ssl option to true in kibaya.yml as show in below. and restart kibana.
    server.ssl.enabled: true

:grinning::smiley:

I have observed that the error is happening only if I run the setup command from local machine to elasticsearch. I was able to import all dashboards properly using a remote machine. Therefore I don't believe that it is related to kibana username/password of ssl enabled or not.

I didnt get your issue. is metricbeat not sending the data to elasticsearch or other issue ?

I don’t think that the issue is Metricbeat related since the filebeat and heartbeat is having the same behavior.