Unable to import metricbeat dashboard

Hello All,

I am using metricbeat6.2.4. I want to export metricbeat dashboard in kibana. I have configured logstash output in my metricbeat.yml file instead of elasticsearch output. My Kibana dashboard is running on different server and i am using nginx webserver.

When is used the below command to import the dashboard i am getting below error:

$ /usr/share/metricbeat/bin/metricbeat setup -e -c /etc/metricbeat/metricbeat.yml


2018-08-20T07:32:00.477Z	INFO	instance/beat.go:468	Home path: [/usr/share/metricbeat/bin] Config path: [/usr/share/metricbeat/bin] Data path: [/usr/share/metricbeat/bin/data] Logs path: [/usr/share/metricbeat/bin/logs]
2018-08-20T07:32:00.478Z	INFO	instance/beat.go:475	Beat UUID: a62b67aa-61ec-44a1-abf0-5632a63ac46f
2018-08-20T07:32:00.478Z	INFO	instance/beat.go:213	Setup Beat: metricbeat; Version: 6.2.4
2018-08-20T07:32:00.480Z	INFO	pipeline/module.go:76	Beat name: orion4
2018-08-20T07:32:00.481Z	ERROR	instance/beat.go:667	Exiting: Template loading requested but the Elasticsearch output is not configured/enabled
Exiting: Template loading requested but the Elasticsearch output is not configured/enabled

Can you please help me how i can import metricbeat dashboard.

Any assistance will be appreciated.

Thanks in advance.

What version of Elasticsearch / Kibana are you using?

It seems the above error comes from the issue that when you run setup it also tries to load the template which it can't. Try adding --dashboard to only load the dashboard.

Hello Ruflin,

Thanks for your response.

After making some changes in my configuration i am able to import the dashboards.

But now i am facing another issue. For some fields i am not getting data on metricbeat dashboard.

Please refer the below screenshot:

I am talking about "The request for this panel failed"

I am getting the below log in my elasticsearch:

Caused by: java.lang.IllegalArgumentException: Fielddata is disabled on text fields by default. Set fielddata=true on [system.network.name] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead.

Note:- I am using ELK6.2.4 as well as Beat 6.2.4 version.

Please suggest.


Did you load the metricbeat index template before you started ingesting data?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.