Cannot start elasticsearch 5.x


(Peter) #1

Hello,

I am running elk stack in docker environment running on coreos but I cannot stat the elasticsearch because vm.max_map_count needs value 2147483648 but the default is 65530.

I have tried creating a config file with that value but I get the following error:

-- Unit systemd-sysctl.service has begun starting up.
Jul 17 20:12:26 core.z0z0.tk systemd-sysctl[741]: Couldn't write '2147483648' to 'vm/max_map_count', ignoring: Invalid argument
Jul 17 20:12:26 core.z0z0.tk systemd[1]: systemd-sysctl.service: Main process exited, code=exited, status=1/FAILURE
Jul 17 20:12:26 core.z0z0.tk sudo[717]: pam_unix(sudo:session): session closed for user root
Jul 17 20:12:26 core.z0z0.tk systemd[1]: Failed to start Apply Kernel Variables.
-- Subject: Unit systemd-sysctl.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel

I know this is not exactly elasticsearch related but maybe there is someone who came up with a solution for this issue.

Thanks in advance
Peter


(Jörg Prante) #2

Please show how you have configured the ES configuration, there is something wrong.

While vm.max_map_count is ok with 65530, ES specific value should be 2^18 (262144), not 2^31 (2147483648). 2^31 is impossible to set by sysctl because this number does not fit into a positive integer value, the maximum integer is 2^31-1 and should not be tried for vm.max_map_count.

https://www.elastic.co/guide/en/elasticsearch/reference/master/_maximum_map_count_check.html


(Peter) #3

elasticsearch config is almost the default one:

cluster.name: cluster
network.host: 0.0.0.0
http.port: 9200
discovery.zen.minimum_master_nodes: 1


(Jörg Prante) #4

I mean the startup configuration where kernel and Java configuration is set, not the Elasticsearch config file in the config directory.


(tomer zaks) #5

Hi jprante,

since I am facing the same problem. Where can i find the kernel and Java configuration is set. I am using Centos.

Many Thanks,
Tomer Zaks


(tomer zaks) #6

When I open my system log I get:

I have elastic Search 5.2 installed


(system) #7