Cannot Start kibana


#1

ElasticSearch: 1.7.4
Kibana: 4.1.0

kibana
{"name":"Kibana","hostname":"Goble004","pid":10872,"level":50,"err":{"message":"Request Timeout after 5000ms","name":"Error","stack":"Error: Request Timeout after 5000ms\n at null. (C:\Users\svelupula\kibana-4.1.0-windows\src\node_modules\elasticsearch\src\lib\transport.js:282:15)\n at Timer.listOnTimeout [as ontimeout] (timers.js:112:15)"},"msg":"","time":"2016-08-08T17:56:42.879Z","v":0}
{"name":"Kibana","hostname":"Goble004","pid":10872,"level":60,"err":{"message":"Request Timeout after 5000ms","name":"Error","stack":"Error: Request Timeout after 5000ms\n at null. (C:\Users\svelupula\kibana-4.1.0-windows\src\node_modules\elasticsearch\src\lib\transport.js:282:15)\n at Timer.listOnTimeout [as ontimeout] (timers.js:112:15)"},"msg":"","time":"2016-08-08T17:56:42.891Z","v":0}


(Jim Unger) #2

Can you provide some more details on your setup?

Are you running both Elasticsearch and Kibana on the same machine?
Are you able to query Elasticsearch outside of Kibana?


#3

ES and kibana is on the same machine. ES is configured with shield. I can hit ES:9200 and can see the ES page.


(Jim Unger) #4

It’s a generic timeout error, basically it took longer than 5 seconds for the cluster to respond to the query.

Check your cluster state.

If you back up your Elasticsearch cluster and try it with a fresh install of Elasticsearch, do you get the same error?

Is this behavior that recently emerged, or has your stack install never worked correctly?


#5

I have installed both ES and kibana yesterday so both are new installs. So far, kibana has never (well only a day since I installed it) worked for me.


#6

ES page says "_cluster health: not connected"

http://localhost:9200/_cluster/health?pretty=true
{
"cluster_name" : "elasticsearch",
"status" : "green",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 0,
"active_shards" : 0,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 0,
"delayed_unassigned_shards" : 0,
"number_of_pending_tasks" : 0,
"number_of_in_flight_fetch" : 0
}


(Jim Unger) #7

Can we eliminate Shield from the picture to start with?

You should be able to disable it in ES by adding shield.enabled: false to your elasticsearch.yml file


(Jim Unger) #8

You also said that you had Shield enabled on Elasticsearch, do you also have it installed on Kibana?


#9

I don't have shield installed/configuread on kibana


(Jim Unger) #10

Is there a reason why you're running those specific versions?


(Jim Unger) #11

If you need to run the 4.1 line, there is a 4.1.11 release. Not sure if it will solve your specific problem, but it'll make the feedback I'm getting from my team more accurate. :wink:


#12

Without shield, ES health cluster is connected and shows green.

Actually thinking what I did.. In Kibana, I did this to configure shield:

esusers useradd kuser -r kuser -p pass

changed the kibana.yml and updated the user and password:
elasticsearch.username: kuser
elasticsearch.password: pass


(Jim Unger) #13

I apologize, but I'm slightly confused. Are you telling me things that you initially configured in order to create the issue, or did you find a solution to your problem?

Are you able to upgrade to 4.1.11?


#14

With version 4.1.0: When I configured ES with shield I also configured kibana with the same info.

4.1.11: I just downloaded this and I see same errors. ES is 1.7.4


(Jim Unger) #15

Please bare with me, as I am trying to reproduce your scenario. I downloaded Kibana 4.1.11, and ES 1.7.4 and have them up and running and talking to each other. (Which it sounds like you did as well)

How did you install Shield? (I want to make sure I follow the same steps)


#16

My OS is Windows 7.

to install shield I did this:
bin/plugin install elasticsearch/license/latest
bin/plugin install elasticsearch/shield/latest


#17

I have elasticsearch-head installed as well..

command:
elasticsearch1.7.4/bin/plugin -install mobz/elasticsearch-head/1.7


#18

So I restarted from scratch, I re installed both kibana and ES (into a different directory than before). Just downloaded ES 1.7.4 (tried 1.7.5 as well) and Kibana 4.1.11 and ran both on the same machine.

kibana does not start, timeout Errors as before.


(Jim Unger) #19

Here are the steps that I took.

  1. Downloaded Elasticsearch 1.7.4
  2. Downloaded Kibana 4.1.11
  3. Unzipped them to respective folders
  4. Installed license to Elasticsearch:
    ./bin/plugin install elasticsearch/license/latest
  5. Installed Shield to Elasticsearch:
    ./bin/plugin install elasticsearch/shield/latest
  6. Added a kibana user to Shield:
    ./bin/shield/esusers useradd kuser -r kibana4 -p password
  7. Added a kibana server user to Shield:
    ./bin/shield/esusers useradd kserver -r kibana4_server -p password
  8. Modified my kibana.yml file to configure the kibana server credentials:
# If your Elasticsearch is protected with basic auth, this is the user credentials
# used by the Kibana server to perform maintence on the kibana_index at statup. Your Kibana
# users will still need to authenticate with Elasticsearch (which is proxied thorugh
# the Kibana server)
kibana_elasticsearch_username: kserver
kibana_elasticsearch_password: password
  1. Start Elasticsearch
    .\bin\elasticsearch
  2. Start Kibana (in kibana folder)
    .\bin\kibana

I was able to log in with the kibana user credentials. Are you able to get this far (without installing the third-party plugin)?


#20

Re ran these exact steps letter to letter. Same error. kibana does not start.