Cannot use own java version in ES 8

Hello, I have ES version 8.1.2 and have env var for ES_JAVA_HOME

But anyway, when I start ES with systemctl start elasticsearch.service it uses bundled jdk.

I found a way how to start it with my own, using override.conf file:
Environment=ES_JAVA_HOME=$(readlink -f /usr/bin/javac | sed "s:/bin/javac::")" >> /etc/systemd/system/elasticsearch.service.d/override.conf
With these settings, it successfully starts with my own JDK.

Can you explain is this an issue?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.