Can't create snapshot repository on Windows cluster


I posted this a while back to the mailing list but didn't get a helpful response unfortunately, and I think I need to try again.

I am trying to create a snapshot repository on a 3 node windows cluster:

PUT _snapshot/main_backup
  "type": "fs",
  "settings": {
    "location": "\\\\gbr-t-ess-003\\Snapshots\\backup2\\",
    "compress": true

I have tried everything I can think of. The machine is one of the nodes in the cluster, and is therefore not blocked by firewall issues. The share is open read/write to everyone, as is the directory at the ACL level. I have tried various versions of the UNC path with no joy.

Has anyone got this working at their end?

The full error:

   "error": "RepositoryException[[main_backup] failed to create repository]; nested: CreationException[Guice creation errors:\r\n\r\n1) Error injecting constructor, org.elasticsearch.common.blobstore.BlobStoreException: Failed to create directory at [\\\\gbr-t-ess-003\\Snapshots\\backup2]\r\n  at org.elasticsearch.repositories.fs.FsRepository.<init>(Unknown Source)\r\n  while locating org.elasticsearch.repositories.fs.FsRepository\r\n  while locating org.elasticsearch.repositories.Repository\r\n\r\n1 error]; nested: BlobStoreException[Failed to create directory at [\\\\gbr-t-ess-003\\Snapshots\\backup2]]; ",
   "status": 500

It would be great if anyone had ideas on this.


p.s. Original mailing list link:!searchin/elasticsearch/windows$20snapshot/elasticsearch/Si8xJ_K5XmY/_8BvSWecFYMJ

Sorry have not tried on windows, though it looks like you are trying to save it to a share not local directory.

This maybe an alternate for you.

Try to share the last directory directly like this:
"location": "\\\\gbr-t-ess-003\\backup2"
(just the server and the share)

I have reproduced your issue, and then tried shorter path and succeeded.
Hope it helps.