Creating Snapshot Repository on Windows cluster

Hi

I'm having some trouble creating a snapshot repository on a cluster running
on Windows.

PUT _snapshot/main_backup
{
"type": "fs",
"settings": {
"location": "\\gbr-t-ess-003\Snapshots\backup2\",
"compress": true
}
}

The above fails with a BlobStoreException: Failed to create directory.

I've set the Share to Everyone Read/Write access to hopefully get this
working but still no good.

I've tried creating symbolic links on each machine and using local
directory path, but no luck either.

Anyone got this working?

Sam

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/070addde-3528-425d-ab43-f1c3e1399e93%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Sorry to bump, but anyone have any idea on this one, as I'm stumped.

Does anyone need any more information?

Sam

On Monday, 20 April 2015 09:57:42 UTC+1, Sam Judson wrote:

Hi

I'm having some trouble creating a snapshot repository on a cluster
running on Windows.

PUT _snapshot/main_backup
{
"type": "fs",
"settings": {
"location": "\\gbr-t-ess-003\Snapshots\backup2\",
"compress": true
}
}

The above fails with a BlobStoreException: Failed to create directory.

I've set the Share to Everyone Read/Write access to hopefully get this
working but still no good.

I've tried creating symbolic links on each machine and using local
directory path, but no luck either.

Anyone got this working?

Sam

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/26f31ff5-d81c-47d3-8cea-94bdc5da65f6%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

this problem may be due to the reason that the directory you are providing
is not accepting Binary data
you can try by changing the directory and provide read-write permissions to
the directory

On Tue, Apr 21, 2015 at 4:40 PM, Sam Judson samjudson@gmail.com wrote:

Sorry to bump, but anyone have any idea on this one, as I'm stumped.

Does anyone need any more information?

Sam

On Monday, 20 April 2015 09:57:42 UTC+1, Sam Judson wrote:

Hi

I'm having some trouble creating a snapshot repository on a cluster
running on Windows.

PUT _snapshot/main_backup
{
"type": "fs",
"settings": {
"location": "\\gbr-t-ess-003\Snapshots\backup2\",
"compress": true
}
}

The above fails with a BlobStoreException: Failed to create directory.

I've set the Share to Everyone Read/Write access to hopefully get this
working but still no good.

I've tried creating symbolic links on each machine and using local
directory path, but no luck either.

Anyone got this working?

Sam

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/26f31ff5-d81c-47d3-8cea-94bdc5da65f6%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/26f31ff5-d81c-47d3-8cea-94bdc5da65f6%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAHzCMpr2PS4%2BbmnNZO6iojkpzZFSEa8c7oVha-8HEcnt_BK5Gw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

the problem might be in your location syntax .
please change the location path to
"location" ;" \gbr-t-ess-003\Snapshots\backup2\"

On Tue, Apr 21, 2015 at 5:04 PM, Deepak Chauhan <
deepak.chauhan@daffodilsw.com> wrote:

this problem may be due to the reason that the directory you are providing
is not accepting Binary data
you can try by changing the directory and provide read-write permissions
to the directory

On Tue, Apr 21, 2015 at 4:40 PM, Sam Judson samjudson@gmail.com wrote:

Sorry to bump, but anyone have any idea on this one, as I'm stumped.

Does anyone need any more information?

Sam

On Monday, 20 April 2015 09:57:42 UTC+1, Sam Judson wrote:

Hi

I'm having some trouble creating a snapshot repository on a cluster
running on Windows.

PUT _snapshot/main_backup
{
"type": "fs",
"settings": {
"location": "\\gbr-t-ess-003\Snapshots\backup2\",
"compress": true
}
}

The above fails with a BlobStoreException: Failed to create directory.

I've set the Share to Everyone Read/Write access to hopefully get this
working but still no good.

I've tried creating symbolic links on each machine and using local
directory path, but no luck either.

Anyone got this working?

Sam

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/26f31ff5-d81c-47d3-8cea-94bdc5da65f6%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/26f31ff5-d81c-47d3-8cea-94bdc5da65f6%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAHzCMprNTnaD2iSMqKQCKrSH0Fnwhwk4cYu4-d-%3DV%3DMUk0_4pw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Hi

Thanks for the reply.Unfortunately I've tried all of those things already.
As I say, I've got the permissions wide open (full control on Everyone) for
both the share and the file system underneath.

You have to escape the UNC path in JSON, I've tried double escaping etc.
with no luck. I've tried the following:

file:////gbr-t-ess-003/Snapshots/backup2
file://gbr-t-ess-003/Snapshots/backup2
////gbr-t-ess-003/Snapshots/backup2
//gbr-t-ess-003/Snapshots/backup2
file:////////gbr-t-ess-003//Snapshots//backup2
\\gbr-t-ess-003\Snapshots\backup2
\\\\gbr-t-ess-003\\Snapshots\\backup2

I've read the Eclipse page on UNC paths
here: http://wiki.eclipse.org/Eclipse/UNC_Paths

None of which has got me any closer to getting this to work unfortunately.

The full error if it helps:

{
"error": "RepositoryException[[main_backup] failed to create
repository]; nested: CreationException[Guice creation errors:\r\n\r\n1)
Error injecting constructor,
org.elasticsearch.common.blobstore.BlobStoreException: Failed to create
directory at [\\gbr-t-ess-003\Snapshots\backup2]\r\n at
org.elasticsearch.repositories.fs.FsRepository.(Unknown Source)\r\n
while locating org.elasticsearch.repositories.fs.FsRepository\r\n while
locating org.elasticsearch.repositories.Repository\r\n\r\n1 error]; nested:
BlobStoreException[Failed to create directory at
[\\gbr-t-ess-003\Snapshots\backup2]]; ",
"status": 500
}

Sam

On Tuesday, 21 April 2015 12:43:47 UTC+1, deepak.chauhan wrote:

the problem might be in your location syntax .
please change the location path to
"location" ;" \gbr-t-ess-003\Snapshots\backup2\"

On Tue, Apr 21, 2015 at 5:04 PM, Deepak Chauhan <deepak....@daffodilsw.com
<javascript:>> wrote:

this problem may be due to the reason that the directory you are
providing is not accepting Binary data
you can try by changing the directory and provide read-write permissions
to the directory

On Tue, Apr 21, 2015 at 4:40 PM, Sam Judson <samj...@gmail.com
<javascript:>> wrote:

Sorry to bump, but anyone have any idea on this one, as I'm stumped.

Does anyone need any more information?

Sam

On Monday, 20 April 2015 09:57:42 UTC+1, Sam Judson wrote:

Hi

I'm having some trouble creating a snapshot repository on a cluster
running on Windows.

PUT _snapshot/main_backup
{
"type": "fs",
"settings": {
"location": "\\gbr-t-ess-003\Snapshots\backup2\",
"compress": true
}
}

The above fails with a BlobStoreException: Failed to create directory.

I've set the Share to Everyone Read/Write access to hopefully get this
working but still no good.

I've tried creating symbolic links on each machine and using local
directory path, but no luck either.

Anyone got this working?

Sam

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/26f31ff5-d81c-47d3-8cea-94bdc5da65f6%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/26f31ff5-d81c-47d3-8cea-94bdc5da65f6%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8b8d07c7-2d0e-4aa5-854a-e1ac6f56ff0e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi Sam,

I am curious about your final solution to this problem. I have a similar case. I have a cluster consisting of a windows and a linux machine.

I installed samba server in the linux machine, and through windows file explorer, I could get in and create and edit files. In the windows machine, I had this line in my elasticsearch.yml:

path.repo: ["\\\\10.162.59.163\\es_ubuntu"]

{
   "error": "RepositoryException[[fht360_backup] failed to create repository]; nested: CreationException[Guice creation errors:\r\n\r\n1) Error injecting constructor, org.elasticsearch.common.blobstore.BlobStoreException: Failed to create directory at [\\\\10.162.59.163\\es_ubuntu\\fht360_backup]\r\n  at org.elasticsearch.repositories.fs.FsRepository.<init>(Unknown Source)\r\n  while locating org.elasticsearch.repositories.fs.FsRepository\r\n  while locating org.elasticsearch.repositories.Repository\r\n\r\n1 error]; nested: BlobStoreException[Failed to create directory at [\\\\10.162.59.163\\es_ubuntu\\fht360_backup]]; ",
   "status": 500
}

I even wrote a C# program to verify that I could create file in that networked directory.

I've posted answer here (it seems like duplicate questions):