Can't get Chef deployed ElasticSearch service to start

I posted this over on Github, but thought I might get more eyeballs here.
I'm deploying an ES cluster to EC2 via OpsWorks using the method described
here: http://blogs.aws.amazon.com/application-management/post/Tx3MEVKS0A4G7R5/Deploying-Elasticsearch-with-OpsWorks

Out of the box, it all works perfectly, but my client requires ES 1.0+ so
I've updated the ES version in the cookbook from 0.90.12 to 1.1.1 by using
the commit
here: https://github.com/elasticsearch/cookbook-elasticsearch/pull/213

If I do the exact same thing, with that one change, I get 502 Bad Gateway
errors from nginx. If I connect via SSH to one of the instances, I notice
elasticsearch is not even running and starting it manually doesn't seem to
work.

[ec2-user@search1 run]$ sudo service elasticsearch status -v
elasticsearch not running
[ec2-user@search1 run]$ sudo service elasticsearch start
PID file found in /usr/local/var/run/search1_localdomain.pid, elasticsearch
already running?
Starting elasticsearch...
[ec2-user@search1 run]$ sudo service elasticsearch status -v
elasticsearch not running

Should there be log files somewhere I can find? Any ideas how to diagnose
this?

Thanks!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/7d07c010-abd4-4ce2-a070-3a29537ba8b0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

see if this helps:
https://github.com/elasticsearch/cookbook-elasticsearch/pull/213

*ryanvanderpol https://github.com/ryanvanderpol *commented on 17 Jul
https://github.com/elasticsearch/cookbook-elasticsearch/pull/213#issuecomment-49336142

Just as a follow up, the issue I was running in to was related to the the
ES service failing to start due to an incompatible plugin. I had to change
the version of the AWS plugin
https://github.com/elasticsearch/elasticsearch-cloud-aws in
/attributes/aws.rb from1.14.0 to 2.1.1

On Wednesday, July 16, 2014 11:33:54 PM UTC+3, Ryan V wrote:

I posted this over on Github, but thought I might get more eyeballs here.
I'm deploying an ES cluster to EC2 via OpsWorks using the method described
here:
http://blogs.aws.amazon.com/application-management/post/Tx3MEVKS0A4G7R5/Deploying-Elasticsearch-with-OpsWorks

Out of the box, it all works perfectly, but my client requires ES 1.0+ so
I've updated the ES version in the cookbook from 0.90.12 to 1.1.1 by using
the commit here:
https://github.com/elasticsearch/cookbook-elasticsearch/pull/213

If I do the exact same thing, with that one change, I get 502 Bad Gateway
errors from nginx. If I connect via SSH to one of the instances, I notice
elasticsearch is not even running and starting it manually doesn't seem to
work.

[ec2-user@search1 run]$ sudo service elasticsearch status -v
elasticsearch not running
[ec2-user@search1 run]$ sudo service elasticsearch start
PID file found in /usr/local/var/run/search1_localdomain.pid,
elasticsearch already running?
Starting elasticsearch...
[ec2-user@search1 run]$ sudo service elasticsearch status -v
elasticsearch not running

Should there be log files somewhere I can find? Any ideas how to diagnose
this?

Thanks!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/4bb09e5a-a5b5-4580-a1cf-ae4a7e5aa67e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

What if you just change the Elasticsearch version in your setup
(attributes, role overrides, etc)? There is no patch/commit needed to
install 1.x versions with the cookbook. (There are just special cases where
overriding attributes doesn't work as expected.)

Is there anything printed to the Elasticsearch log? Are you able to start
Elasticsearch directly by executing the bin/elasticsearch script?

Karel

On Wednesday, July 16, 2014 10:33:54 PM UTC+2, Ryan V wrote:

I posted this over on Github, but thought I might get more eyeballs here.
I'm deploying an ES cluster to EC2 via OpsWorks using the method described
here:
http://blogs.aws.amazon.com/application-management/post/Tx3MEVKS0A4G7R5/Deploying-Elasticsearch-with-OpsWorks

Out of the box, it all works perfectly, but my client requires ES 1.0+ so
I've updated the ES version in the cookbook from 0.90.12 to 1.1.1 by using
the commit here:
https://github.com/elasticsearch/cookbook-elasticsearch/pull/213

If I do the exact same thing, with that one change, I get 502 Bad Gateway
errors from nginx. If I connect via SSH to one of the instances, I notice
elasticsearch is not even running and starting it manually doesn't seem to
work.

[ec2-user@search1 run]$ sudo service elasticsearch status -v
elasticsearch not running
[ec2-user@search1 run]$ sudo service elasticsearch start
PID file found in /usr/local/var/run/search1_localdomain.pid,
elasticsearch already running?
Starting elasticsearch...
[ec2-user@search1 run]$ sudo service elasticsearch status -v
elasticsearch not running

Should there be log files somewhere I can find? Any ideas how to diagnose
this?

Thanks!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/85569672-cde5-4254-98df-acb28d2876d5%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.