How do I start elasticsearch as a service?


(Eric Greene) #1

Forgive me I'm a little lost.

I am working on deploying elasticsearch on a AWS server. Previously in
development I have started elasticsearch using ./bin/elasticsearch
-Des.config=/etc/elasticsearch/elasticsearch.yml

But in live deployment, I want to keep elasticsearch running as a service...

I have 1.2.0 installed on Ubuntu 12.04 on my AWS instance.

I run sudo /etc/init.d/elasticsearch start and I get:

  • Starting Elasticsearch server

I check sudo /etc/init.d/elasticsearch status and I get:

  • elasticsearch is not running

I'm not sure how to troubleshoot. Any advice or suggestions? Thanks

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1c191994-ba5c-495d-b5e8-4e0bed3c4845%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #2

Check the logs under /var/log/elasticsearch, they should have something.

Also please be aware that 1.2.0 has a critical bug and you should be using
1.2.1 instead.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 27 August 2014 08:42, Eric Greene ericdgreene@gmail.com wrote:

Forgive me I'm a little lost.

I am working on deploying elasticsearch on a AWS server. Previously in
development I have started elasticsearch using ./bin/elasticsearch
-Des.config=/etc/elasticsearch/elasticsearch.yml

But in live deployment, I want to keep elasticsearch running as a
service...

I have 1.2.0 installed on Ubuntu 12.04 on my AWS instance.

I run sudo /etc/init.d/elasticsearch start and I get:

  • Starting Elasticsearch server

I check sudo /etc/init.d/elasticsearch status and I get:

  • elasticsearch is not running

I'm not sure how to troubleshoot. Any advice or suggestions? Thanks

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/1c191994-ba5c-495d-b5e8-4e0bed3c4845%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/1c191994-ba5c-495d-b5e8-4e0bed3c4845%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624Ya1xeRTaebytv9D8Zv9zTK-7XoB3zK4vhvRNHQuX%3DgMQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Eric Greene) #3

Thanks Mark, I found that if I comment out the line in elasticsearch.yml
that sets the data path, it works.

I will upgrade as you have suggested, thanks for that.

On Tuesday, August 26, 2014 4:04:05 PM UTC-7, Mark Walkom wrote:

Check the logs under /var/log/elasticsearch, they should have something.

Also please be aware that 1.2.0 has a critical bug and you should be using
1.2.1 instead.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com <javascript:>
web: www.campaignmonitor.com

On 27 August 2014 08:42, Eric Greene <ericd...@gmail.com <javascript:>>
wrote:

Forgive me I'm a little lost.

I am working on deploying elasticsearch on a AWS server. Previously in
development I have started elasticsearch using ./bin/elasticsearch
-Des.config=/etc/elasticsearch/elasticsearch.yml

But in live deployment, I want to keep elasticsearch running as a
service...

I have 1.2.0 installed on Ubuntu 12.04 on my AWS instance.

I run sudo /etc/init.d/elasticsearch start and I get:

  • Starting Elasticsearch server

I check sudo /etc/init.d/elasticsearch status and I get:

  • elasticsearch is not running

I'm not sure how to troubleshoot. Any advice or suggestions? Thanks

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/1c191994-ba5c-495d-b5e8-4e0bed3c4845%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/1c191994-ba5c-495d-b5e8-4e0bed3c4845%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/58806f15-0a63-44f6-9a35-85a460384fa5%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #4

The line is probably just malformed then :slight_smile:

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 27 August 2014 09:27, Eric Greene ericdgreene@gmail.com wrote:

Thanks Mark, I found that if I comment out the line in elasticsearch.yml
that sets the data path, it works.

I will upgrade as you have suggested, thanks for that.

On Tuesday, August 26, 2014 4:04:05 PM UTC-7, Mark Walkom wrote:

Check the logs under /var/log/elasticsearch, they should have something.

Also please be aware that 1.2.0 has a critical bug and you should be
using 1.2.1 instead.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com
web: www.campaignmonitor.com

On 27 August 2014 08:42, Eric Greene ericd...@gmail.com wrote:

Forgive me I'm a little lost.

I am working on deploying elasticsearch on a AWS server. Previously in
development I have started elasticsearch using ./bin/elasticsearch
-Des.config=/etc/elasticsearch/elasticsearch.yml

But in live deployment, I want to keep elasticsearch running as a
service...

I have 1.2.0 installed on Ubuntu 12.04 on my AWS instance.

I run sudo /etc/init.d/elasticsearch start and I get:

  • Starting Elasticsearch server

I check sudo /etc/init.d/elasticsearch status and I get:

  • elasticsearch is not running

I'm not sure how to troubleshoot. Any advice or suggestions? Thanks

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/1c191994-ba5c-495d-b5e8-4e0bed3c4845%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/1c191994-ba5c-495d-b5e8-4e0bed3c4845%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/58806f15-0a63-44f6-9a35-85a460384fa5%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/58806f15-0a63-44f6-9a35-85a460384fa5%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624aDG-yDjhRvKDo8ViiQaxtHWpzCa_cSU5uq4CBf-8fnSQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #5