Can't get disk information (Windows) - Metricbeat 7.12.0

Hi everyone.

After a couple of minutes searching and trying out solutions, I still can't get information about the filesystem and fsstat of, for example of the C drive on my Windows Server.

image


Tried the following configurations on system.yaml:

  • With and without the default drop.event...regex:
  • Ignore.filetype (cdrom and shared disk)


Also, the communication between metricbeat and elasticsearch is working since I get other data.

Everything is the same version: 7.12.0

The logs and running metricbeat -e -d "*" show the same error.


[Important] I found this discussion and it seems like the problem isn't indeed fixed.


Ayway. I appreciate any further help or status about the situation.

Thanks and have a great day.

hi @ruivit , the issue to follow is [Metricbeat] Filesystem Metricset: Inconsistent system.filesystem.type values on Windows · Issue #22501 · elastic/beats (github.com) . The fix has not made in 7.12 unfortunately but will most likely make it in the next release.

Okay then. Thanks for the update on the issue.

I've actually found the solution, it uses the perfmom module.
Just leaving it here for someone who's facing the same issue.

  • Tested with Windows Server 206 & 2019
  • Metricbeat 7.12.0 (and ELK Stack)

Get Free Disk Percentage

- module: windows
  metricsets: ["perfmom"]
  enabled: true
  period: 5m
  perfmom.queries:
    - object: '\LogicalDisk'
      namespace: logicaldisk
      instance: "C:" (or "*" for all drives)
      counters:
        - name: '% Free Space'
          label: logicaldisk.free.space