Can't log in to Kibana


#1

I am running an Elasticsearch cluster with 3 nodes. 2 are data nodes and one is the co-ordinating node. There is currently no data being sent to Elasticsearch yet.

I have secured my Elasticsearch cluster with HTTPS and TLS/SSL connection using self-signed certificates.

I am running an instance of Kibana to listen to the co-ordinating node. However when I start up kibana I get this error from my log:

{"type":"log","@timestamp":"2018-02-28T21:00:16Z","tags":["warning","elasticsearch","admin"],"pid":1,"message":"Unable to revive connection: https://:9200/"}

I can visit the log in page for Kibana and get this error message: "Login is currently disabled. Administrators should consult the Kibana logs for more details."

As a result I am unable to log in. In my elasticsearch.yml and kibana.yml i have set my user and pass to be the same (elastic and changeme)

Any help would be appreciated!


(Joe Fleming) #2

Login is currently disabled

So it sounds like you're trying to use the X-Pack security feature. Usually when Kibana shows that message, it's because it can't talk to Elasticsearch or you have an invalid license. Based on the log message you posted, it seems like you're dealing with the former.

Interestingly, there's no hostname in the log output. Are you setting a custom hostname in the kibana.yml? And can you share the other settings you've got in there (without the security keys or any other sensitive data)?


#4

@Joe_Fleming

Regarding the log message, it does show the hostname. I just blanked it out for privacy. So it should read something like "Unable to revive connection: https://<<hostname>>:9200"

Here is what I got in my kibana.yml

server.name: kibana
server.host: "0.0.0.0"
elasticsearch.url: "https://<<hostname>>:9200"
elasticsearch.username: "{{ kibana_username }}"
elasticsearch.password: "{{ kibana_password }}"

{{ kibana_username }} and {{ kibana_password }} resolves to elastic and changeme respectively.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.