Can't run ElasticSearch

Hey guys,

I try to install ElasticSearch but when I download it and try to set it up via the command window it looks like the following:

'// C:\Users\josef>cd C:\Program Files\elasticsearch-7.8.0

C:\Program Files\elasticsearch-7.8.0>bin\elasticsearch.bat
"Files\elasticsearch-7.8.0\jdk""" kann syntaktisch an dieser Stelle nicht verarbeitet werden.'

Can anybody help me with that? Thank you in advance.

Having the same problem.
Just posting so it gets up

Google translate tells me that is;

cannot be processed syntactically at this point

Is that right>

I tried it again with an english language package.
The Output is:

Files\elasticsearch-7.8.0\jdk"" was unexpected at this time

Seems like it cut of the path, because my installation is in C:\Program Files

I don't think it works well with directories that have spaces in the name, try another directory.

Ok it's weird that 7.7 doesn't have this issue.

Tried it with another folder without a space in it's name.
Now i get the following exception:

Error: Could not find or load main class org.elasticsearch.common.settings.KeyStoreCli
Caused by: java.lang.NoClassDefFoundError: org/elasticsearch/cli/LoggingAwareMultiComman
Error: Could not find or load main class org.elasticsearch.bootstrap.Elasticsearch
Caused by: java.lang.ClassNotFoundException: org.elasticsearch.bootstrap.Elasticsearch

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.