Can't turn back index.translog.durability to request


(Marcus Vinicius) #1

Hello everyone!

I am using Elasticsearch in version 5.1.1. Recently i've changed my translog durability to async.

I am trying to turn back my index.translog.durability from async to request but i am receiving acknowledge false.

What can i do to go back with syncronous requests?


(David Pilato) #2

Yes. request should be good.

What command did you call exactly?


(Marcus Vinicius) #3

PUT > http://localhost:9200/_settings

{
  "index.translog.durability" : "request"
}

(Marcus Vinicius) #4

I got this response:

{
  "acknowledged": false
}

(David Pilato) #5

You are missing the index name.


(Marcus Vinicius) #6

I tryed to send to _all but don't worked again.

/_all/_settings

How can i send this request to all indices?


(David Pilato) #7

This worked well for me:

curl -XDELETE "http://localhost:9200/test?pretty"
curl -XPUT "http://localhost:9200/test?pretty"
curl -XPUT "http://localhost:9200/test/_settings?pretty" -d '{
  "index.translog.durability" : "async"
}'
curl -XPUT "http://localhost:9200/test/_settings?pretty" -d '{
  "index.translog.durability" : "request"
}'

I don't think you can do that for all indices. But I think it's easy to script that.


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.