Canvas Timefilter not allowing me to select a time range

Hi,

This is an issue that has just happened recently and I am on v7.9.1. When I try and select a time range on my canvas workpad using the Timefilter, the dropdown with the range of values does not appear. All I can do with it is move the filter around.

My user role has not changed and before now I was able to change the time range. Is there anyway to fix this/why might this have happened?

Hi @hNiven,

It looks like you might face this filter issue , it should be fixed in 7.10.0. That said, you have to update Elastic stack in order to make Canvas time filter work properly.

Regards, Dzmitry

Hi @Dzmitry,

Thank you for the quick reply. After having a look at the issue linked, it looks different to the problem I am facing as I cannot even change the date or time like they can in the issue report. I cannot interact with the filter beyond being able to move it about.

After some more investigation, I have seen that the problem may be due to the version of chrome that I am using.

Others that are using the exact same environment/version of Kibana as me are able to interact with the Timefilter as intended and are on an older version of chrome: 88.0.4324.190
Whereas I am on a newer version of chrome: 94.0.4606.81

Could this be affecting the way the Timefilter on canvas works at all?

I just tried Canvas data picker on workpad from our sample data (Kibana version 7.15.1) on Chrome 94.0.4606.71 and I don't see any problems. I'm not aware of any Chrome version specific issues related to Canvas, but it could be the case. Also using some 3rd party plugins in your browser may cause an issue, so might want to check it with your colleagues as well

Regards, Dzmitry

I seem to have the same problem with chrome. Also happens in private window. Firefox works fine.

Yeah have seen firefox working fine too, also managed to setup an old version of chrome which it was working on as well

The problem seems to be with position: relative.

I added a Quickfix in my global css overrides, as a workaround.

.canvasRenderEl .euiPopover,
.canvasRenderEl .euiFormControlLayout__childrenWrapper {
  position: static;
}
1 Like

@mmR, Yeah this has done the trick, thank you!

On a similar note have you managed to find any work around for the same issue but regarding the dropdown filter, I tried this solution as well but to no success.

@hNiven dropdown filter seems to work for me out of the box. So sorry cant reproduce → cant fix.