Carrot plugin for elasticsearch (installing error)


(Navneet Mathpal) #1

Hi ,

I am trying to install carrot plugin for elasticsearch , but with all the version of elasticsearch I am getting an error that

Verifying file:/I:/elastic_carrot/carrot.zip checksums if available ...
NOTE: Unable to verify checksum for downloaded plugin (unable to find .sha1 or .md5 file to verify)
ERROR: Could not find plugin descriptor 'plugin-descriptor.properties' in plugin zip

I have tried this with all the version of elasticsearh(1.7 and 2.3) but getting the same error.

I am not installing this online because network does not allow this . not I am installing this through zip.

any help?

Thanks,
Navneet


(David Pilato) #2

Where did you get the zip file?


(Navneet Mathpal) #3

@dadoonet - https://github.com/carrot2/elasticsearch-carrot2


(David Pilato) #4

So you probably downloaded the source code, right?

What do you have in your zip?

Try to find where the released artifact is hosted. Probably on maven central. Download it from there.

You can use the verbose option of the plugin manager to have an idea of where the artifact can be found.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.