Caused by: java.lang.IllegalStateException: jar hell!


(Mohd Afeef) #1

After Installing Pom.xml of High Level Client i was not able to start elastic search in local machine.

i tried to run localhost:9200

it's giving error

Caused by: java.lang.IllegalStateException: jar hell!
class: org.elasticsearch.protocol.xpack.migration.UpgradeActionRequired

Error Logs

http://s000.tinyupload.com/?file_id=72583965491514617327

Pom.xml
http://s000.tinyupload.com/index.php?file_id=75392939271015990471

I tried to find link

I have tried all except disabling jar hell.

after lots googling i came to know i have used repeat lib in pom.xml

but i couldn't find such case in my pom.xml .

Any suggestion is most welcome.


(Mohd Afeef) #2

Jar Hell is about Jar conflicts

jar1: C:\Program Files\elasticsearch-6.5.1\modules\x-pack-core\x-pack-core-6.5.1.jar

jar2: C:\Program Files\elasticsearch-6.5.1\lib\elasticsearch-rest-high-level-client-6.5.1.jar

I have removed elasticsearch-rest-high-level-client jar file from lib folder.

It Resolved The problem