Jar Hell Error in 5.5.3


(Aditi G) #1

Hi,

I am getting the below error after I tried start elasticsearch on a Linux RHEL 6 server with java -version
openjdk version "1.8.0_171".
I have used the tar file for this app.

[2018-06-05T00:32:15,527][WARN ][o.e.b.ElasticsearchUncaughtExceptionHandler] [node-1] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: jar hell!
duplicate jar [/opt/elasticsearch/lib/elasticsearch-5.5.3.jar] on classpath: /opt/elasticsearch/lib/elasticsearch-5.5.3.jar:/opt/elasticsearch/lib/joda-time-2.9.5.jar:/opt/elasticsearch/lib/jackson-dataformat-cbor-2.8.6.jar:/opt/elasticsearch/lib/jackson-core-2.8.6.jar:/opt/elasticsearch/lib/lucene-queryparser-6.6.0.jar:/opt/elasticsearch/lib/lucene-misc-6.6.0.jar:/opt/elasticsearch/lib/lucene-queries-6.6.0.jar:/opt/elasticsearch/lib/lucene-suggest-6.6.0.jar:/opt/elasticsearch/lib/lucene-core-6.6.0.jar:/opt/elasticsearch/lib/spatial4j-0.6.jar:/opt/elasticsearch/lib/hppc-0.7.1.jar:/opt/elasticsearch/lib/securesm-1.1.jar:/opt/elasticsearch/lib/jts-1.13.jar:/opt/elasticsearch/lib/lucene-spatial-6.6.0.jar:/opt/elasticsearch/lib/jopt-simple-5.0.2.jar:/opt/elasticsearch/lib/lucene-spatial-extras-6.6.0.jar:/opt/elasticsearch/lib/lucene-backward-codecs-6.6.0.jar:/opt/elasticsearch/lib/jackson-dataformat-yaml-2.8.6.jar:/opt/elasticsearch/lib/lucene-spatial3d-6.6.0.jar:/opt/elasticsearch/lib/HdrHistogram-2.1.9.jar:/opt/elasticsearch/lib/lucene-sandbox-6.6.0.jar:/opt/elasticsearch/lib/lucene-analyzers-common-6.6.0.jar:/opt/elasticsearch/lib/elasticsearch-5.5.3.jar:/opt/elasticsearch/lib/t-digest-3.0.jar:/opt/elasticsearch/lib/jna-4.4.0.jar:/opt/elasticsearch/lib/snakeyaml-1.15.jar:/opt/elasticsearch/lib/java-version-checker-5.5.3.jar:/opt/elasticsearch/lib/plugin-cli-5.5.3.jar:/opt/elasticsearch/lib/lucene-highlighter-6.6.0.jar:/opt/elasticsearch/lib/log4j-api-2.8.2.jar:/opt/elasticsearch/lib/lucene-grouping-6.6.0.jar:/opt/elasticsearch/lib/lucene-join-6.6.0.jar:/opt/elasticsearch/lib/log4j-1.2-api-2.8.2.jar:/opt/elasticsearch/lib/lucene-memory-6.6.0.jar:/opt/elasticsearch/lib/jackson-dataformat-smile-2.8.6.jar:/opt/elasticsearch/lib/log4j-core-2.8.2.jar
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:127) ~[elasticsearch-5.5.3.jar:5.5.3]
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:114) ~[elasticsearch-5.5.3.jar:5.5.3]
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:67) ~[elasticsearch-5.5.3.jar:5.5.3]
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122) ~[elasticsearch-5.5.3.jar:5.5.3]
at org.elasticsearch.cli.Command.main(Command.java:88) ~[elasticsearch-5.5.3.jar:5.5.3]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91) ~[elasticsearch-5.5.3.jar:5.5.3]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84) ~[elasticsearch-5.5.3.jar:5.5.3]
Caused by: java.lang.IllegalStateException: jar hell!
duplicate jar [/opt/elasticsearch/lib/elasticsearch-5.5.3.jar] on classpath: /opt/elasticsearch/lib/elasticsearch-5.5.3.jar:/opt/elasticsearch/lib/joda-time-2.9.5.jar:/opt/elasticsearch/lib/jackson-dataformat-cbor-2.8.6.jar:/opt/elasticsearch/lib/jackson-core-2.8.6.jar:/opt/elasticsearch/lib/lucene-queryparser-6.6.0.jar:/opt/elasticsearch/lib/lucene-misc-6.6.0.jar:/opt/elasticsearch/lib/lucene-queries-6.6.0.jar:/opt/elasticsearch/lib/lucene-suggest-6.6.0.jar:/opt/elasticsearch/lib/lucene-core-6.6.0.jar:/opt/elasticsearch/lib/spatial4j-0.6.jar:/opt/elasticsearch/lib/hppc-0.7.1.jar:/opt/elasticsearch/lib/securesm-1.1.jar:/opt/elasticsearch/lib/jts-1.13.jar:/opt/elasticsearch/lib/lucene-spatial-6.6.0.jar:/opt/elasticsearch/lib/jopt-simple-5.0.2.jar:/opt/elasticsearch/lib/lucene-spatial-extras-6.6.0.jar:/opt/elasticsearch/lib/lucene-backward-codecs-6.6.0.jar:/opt/elasticsearch/lib/jackson-dataformat-yaml-2.8.6.jar:/opt/elasticsearch/lib/lucene-spatial3d-6.6.0.jar:/opt/elasticsearch/lib/HdrHistogram-2.1.9.jar:/opt/elasticsearch/lib/lucene-sandbox-6.6.0.jar:/opt/elasticsearch/lib/lucene-analyzers-common-6.6.0.jar:/opt/elasticsearch/lib/elasticsearch-5.5.3.jar:/opt/elasticsearch/lib/t-digest-3.0.jar:/opt/elasticsearch/lib/jna-4.4.0.jar:/opt/elasticsearch/lib/snakeyaml-1.15.jar:/opt/elasticsearch/lib/java-version-checker-5.5.3.jar:/opt/elasticsearch/lib/plugin-cli-5.5.3.jar:/opt/elasticsearch/lib/lucene-highlighter-6.6.0.jar:/opt/elasticsearch/lib/log4j-api-2.8.2.jar:/opt/elasticsearch/lib/lucene-grouping-6.6.0.jar:/opt/elasticsearch/lib/lucene-join-6.6.0.jar:/opt/elasticsearch/lib/log4j-1.2-api-2.8.2.jar:/opt/elasticsearch/lib/lucene-memory-6.6.0.jar:/opt/elasticsearch/lib/jackson-dataformat-smile-2.8.6.jar:/opt/elasticsearch/lib/log4j-core-2.8.2.jar
at org.elasticsearch.bootstrap.JarHell.parseClassPath(JarHell.java:142) ~[elasticsearch-5.5.3.jar:5.5.3]
at org.elasticsearch.bootstrap.JarHell.parseClassPath(JarHell.java:99) ~[elasticsearch-5.5.3.jar:5.5.3]
at org.elasticsearch.bootstrap.JarHell.checkJarHell(JarHell.java:90) ~[elasticsearch-5.5.3.jar:5.5.3]
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:220) ~[elasticsearch-5.5.3.jar:5.5.3]
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:351) ~[elasticsearch-5.5.3.jar:5.5.3]
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:123) ~[elasticsearch-5.5.3.jar:5.5.3]

Can you please help.


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.