Caused by: org.elasticsearch.action.search.SearchPhaseExecutionException

Caused by: org.elasticsearch.action.search.SearchPhaseExecutionException: Search rejected due to missing shards [[.kibana_task_manager_7.14.0_001][0]]. Consider using allow_partial_search_results setting to bypass this error .",

Hi All,

Above error we are getting.
Envrionment details:
ElasticSearch deployed as standalone pod in Kubernetes
Kibana deployed as standalone pod in Kubernetes

We have tried with both 7.14 and 7.12 version.

The data gets ingestion in ElasticSearch and we are able to also view in Kibana but after few hours above mentioned error we get and then Kibana goes down.

We have also tried 'allow_partial_search_results', setting to True and False both the ways as by default its True, but still its not working.

We also have tried restarting pods/redeployments but everytime it works for few hours and then in logs we get the above mentioned error.
Any suggestion would be of great help.

Regards,
Pradeep

Is that an error you're seeing in the logs or in the Kibana UI?