Changing URL in alerts without updating server.publicBaseUrl

I am an Elastic Cloud user. For simplicity, our users access Kibana over port 443, rather than port 9243, and this is how our SSO solution is configured as well.

We are setting up alerts in Elastic, and one of the field options is context.linkMessage, which inserts a link into the alert that takes the user to the appropriate place in the console to view it.

However, in Elastic Cloud, it includes port 9243, which fails to authenticate through our SSO. Is there a way I could modify this? I suspect that I could do it by setting server.publicBaseUrl for our instance, but I suspect that would be break things and be a Very Bad Thing.

Are there other options? Getting just the part of the URL starting after https://host:port/ would be fine, but I don't see a way to do that.