Checking ReIndex Status - Seems wrong, why?

I'm going off of Kibana document page at:

I ran the "reindex status" command and am seeing this result in the browser:

This result appears wrong because if I run the following command manually every minute, I can see the number of docs in my new index increasing:

GET _cat/shards?v

gives me a result like:

Why does my "reindex status" call give me a null result for reindexOp.status? Based on the documentation at it shouldn't be null, there are quite a few fields within reindexOp.


Going to answer my own question, maybe it will help someone else out. Based on doc at, use ?wait_for_completion=false. Then after running the below command, it will give you a task id.

POST _reindex?wait_for_completion=false
        "source": {
          "index": "old-index"
        "dest": {
          "index": "wes-new-index"

Given that task id, run below command with the task id to see the status of the reindex. Elasticsearch creates a record of this task as a document at .tasks/_doc/${taskId}

 GET /_tasks/J3fHlMBpSOiyxgGE0CRtIQ:246897

While this solution doesn't answer my original question, it is an alternative way of getting the status of an reindex operation. I did notice that original way of trying to figure out reindex status was an experimental api call, think it might be buggy.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.