Chef-solo monit and elasticsearch version issues


(Jan Backes) #1

Hi,

I am currently trying to install elasticsearch on amazon (amazon ami) using
the chef-solo tutorial (
http://www.elasticsearch.org/tutorials/deploying-elasticsearch-with-chef-solo/).
I followed this tutorial couple months ago and was successfully running an
ES cluster since then.

While doing a "test-run" I realised that the monit version is rather old
and that it is not inline any longer with the updated cookbook resulting in
an error (e.g.
https://github.com/elasticsearch/cookbook-elasticsearch/issues/184). I
changed this by pulling the newest version from
https://github.com/apsoto/monit and it installs just fine.

Now I am just wondering why I am getting a "green" for the cluster health
check:

Remote Host 'elasticsearch_cluster_health'
status online with all services
monitoring status monitored
port response time 0.008s to
0.0.0.0:9200/_cluster/health[HTTP via TCP]
data collected Sat Mar 22 11:39:32 2014

Should the cluster health check fail since it is only one node?

I also tried to update the version to 1.0.1. For that I spun up another
instance using the same settings - but changing the version number in


1.0.1. I saw that there are many issues/pull request regarding the
upgrade - so I was thinking that a fresh install would avoid all this.

The bootstrap script and everything runs fine - but the es service will not
start. Trying to start es manually show the error:

{1.0.1}: Initialization Failed ...

  • ElasticsearchIllegalStateException[Failed to obtain node lock, is the
    following location writable?:
    [/usr/local/elasticsearch-1.0.1/data/elasticsearch]]
    IOException[failed to obtain lock on
    /usr/local/elasticsearch-1.0.1/data/elasticsearch/nodes/49]
    IOException[Cannot create directory:
    /usr/local/elasticsearch-1.0.1/data/elasticsearch/nodes/49]

Now I am wondering how to adjust the cookbook to set the paths right and
avoid the lock error. Or is there another preferred way of upgrading?

I also tried this using ubuntu server (using the updated setup instruction
etc from the elasticsearch-cookbook github page) and ran into the same
issues. Maybe somebody has similar issues/experiences.

Thanks a lot for your help,
Jan

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKzGBByCxf0ny9MYQOqMCV%3DT5RofSz6ziwwKLd5CsC4AWcDbTQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #2