Cluster health yellow on one node even when setting node.local to true


(w.pink) #1

Hi,

I have a single node instance that I want to run ES on, I have set '
node.local: true' and disabled the Discovery but still the cluster health
is yellow. I'm running
Elasticsearch version 1.1.0

Thanks,
Will

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0db93c88-c199-474a-b205-39432bdf2354%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jörg Prante) #2

You have to set the replica level from 1 to 0 on single node to switch
health from yellow to green.

Jörg

On Mon, Sep 8, 2014 at 5:41 PM, w.pink@tape.tv wrote:

Hi,

I have a single node instance that I want to run ES on, I have set '
node.local: true' and disabled the Discovery but still the cluster health
is yellow. I'm running
Elasticsearch version 1.1.0

Thanks,
Will

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/0db93c88-c199-474a-b205-39432bdf2354%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/0db93c88-c199-474a-b205-39432bdf2354%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoH8O2G3cVpgTfgV-AW9NDATsQnO0iuDED2aCi-bGxObrA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(w.pink) #3

I've set

index.number_of_replicas: 0

Is there something else I need to set?

Thanks
On Monday, 8 September 2014 17:56:56 UTC+2, Jörg Prante wrote:

You have to set the replica level from 1 to 0 on single node to switch
health from yellow to green.

Jörg

On Mon, Sep 8, 2014 at 5:41 PM, <w.p...@tape.tv <javascript:>> wrote:

Hi,

I have a single node instance that I want to run ES on, I have set '
node.local: true' and disabled the Discovery but still the cluster
health is yellow. I'm running
Elasticsearch version 1.1.0

Thanks,
Will

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/0db93c88-c199-474a-b205-39432bdf2354%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/0db93c88-c199-474a-b205-39432bdf2354%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/868a1160-8c4a-46d5-9a34-951e61cc2569%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4