Cluster state yellow after upgrade to 1.0


(Mohit Anchlia) #1

I just upgraded from .90 to 1.0 and my cluster state is showing yellow:

Not sure why one node doesn't show up as "m"

[root@ip-10-80-140-59 ec2-user]# curl 'localhost:9200/_cat/nodes'

17 5 1.47 d m 10.80.140.62

22 4 0.00 d m 10.80.140.58

27 5 0.55 d * 10.80.140.59

21 4 0.06 d m 10.80.140.13

[root@ip-10-80-140-59 ec2-user]# curl 'localhost:9200/_cat/indices'

yellow test2 5 1 186936800 0 79gb 49.4gb

green test1 5 1 142163219 0 76.9gb 38.4gb

[root@ip-10-80-140-59 ec2-user]#

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAOT3TWpCeH0a_ic%3DjVO%3D787RA7Zr_qH8N5ob_fdOKn0MfoffNA%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Mohit Anchlia) #2

I also see some shards in INITIALIZING

[root@ip-10-80-140-59 ec2-user]# curl 'localhost:9200/_cat/shards/test2'

test2 2 p STARTED 37382168 9.8gb 10.80.140.59

test2 2 r INITIALIZING 10.80.140.62

test2 0 p STARTED 37382444 9.8gb 10.80.140.59

test2 0 r STARTED 37382444 9.8gb 10.80.140.62

test2 3 p STARTED 37388544 9.8gb 10.80.140.59

test2 3 r STARTED 37388544 9.8gb 10.80.140.62

test2 1 p STARTED 37389978 9.8gb 10.80.140.59

test2 1 r STARTED 37389978 9.8gb 10.80.140.62

test2 4 p STARTED 37393666 9.8gb 10.80.140.59

test2 4 r INITIALIZING 10.80.140.62

On Mon, Feb 17, 2014 at 11:44 AM, Mohit Anchlia mohitanchlia@gmail.comwrote:

I just upgraded from .90 to 1.0 and my cluster state is showing yellow:

Not sure why one node doesn't show up as "m"

[root@ip-10-80-140-59 ec2-user]# curl 'localhost:9200/_cat/nodes'

17 5 1.47 d m 10.80.140.62

22 4 0.00 d m 10.80.140.58

27 5 0.55 d * 10.80.140.59

21 4 0.06 d m 10.80.140.13

[root@ip-10-80-140-59 ec2-user]# curl 'localhost:9200/_cat/indices'

yellow test2 5 1 186936800 0 79gb 49.4gb

green test1 5 1 142163219 0 76.9gb 38.4gb

[root@ip-10-80-140-59 ec2-user]#

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAOT3TWq6%2B6yhNHan1rMhSE2vvqTxEPbVr%2B%2BB0Y3haprAO_C%2BxQ%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Boaz Leskes) #3

Hi Mo,

The m indicates that all nodes may become master. The * means that node
is the current master. There is nothing wrong with that.

Your cluster is yellow because not all shards are started. If things don't
sort out themselves within a couple of minutes (usually much quicker),
something is going on.

Cheers,
Boaz

On Monday, February 17, 2014 8:45:58 PM UTC+1, Mo wrote:

I also see some shards in INITIALIZING

[root@ip-10-80-140-59 ec2-user]# curl 'localhost:9200/_cat/shards/test2'

test2 2 p STARTED 37382168 9.8gb 10.80.140.59

test2 2 r INITIALIZING 10.80.140.62

test2 0 p STARTED 37382444 9.8gb 10.80.140.59

test2 0 r STARTED 37382444 9.8gb 10.80.140.62

test2 3 p STARTED 37388544 9.8gb 10.80.140.59

test2 3 r STARTED 37388544 9.8gb 10.80.140.62

test2 1 p STARTED 37389978 9.8gb 10.80.140.59

test2 1 r STARTED 37389978 9.8gb 10.80.140.62

test2 4 p STARTED 37393666 9.8gb 10.80.140.59

test2 4 r INITIALIZING 10.80.140.62

On Mon, Feb 17, 2014 at 11:44 AM, Mohit Anchlia <mohita...@gmail.com<javascript:>

wrote:

I just upgraded from .90 to 1.0 and my cluster state is showing yellow:

Not sure why one node doesn't show up as "m"

[root@ip-10-80-140-59 ec2-user]# curl 'localhost:9200/_cat/nodes'

17 5 1.47 d m 10.80.140.62

22 4 0.00 d m 10.80.140.58

27 5 0.55 d * 10.80.140.59

21 4 0.06 d m 10.80.140.13

[root@ip-10-80-140-59 ec2-user]# curl 'localhost:9200/_cat/indices'

yellow test2 5 1 186936800 0 79gb 49.4gb

green test1 5 1 142163219 0 76.9gb 38.4gb

[root@ip-10-80-140-59 ec2-user]#

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/95c8d401-ddc3-4922-b2ab-47453ad879a2%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4