Combine elasticsearch 5.1.1 and repository hdfs


(张宇鹏) #1

The hdfs attribute on elasticsearch.yml does not seem to be recognized

my elasticsearch.yml file

repositories:
  hdfs:
    uri: "hdfs://es-master:9000/" # optional - Hadoop file-system URI
    path: "some/path" # required - path with the file-system where data is stored/loaded

the error message:

[2016-12-21T04:49:58,120][WARN ][o.e.b.ElasticsearchUncaughtExceptionHandler] [node-1] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalArgumentException: unknown setting [repositories.hdfs.path] please check that any required plugins are inst alled, or check the breaking changes documentation for removed settings
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:125) ~[elasticsearch-5.1.1.jar:5.1.1]
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112) ~[elasticsearch-5.1.1.jar:5.1.1]
at org.elasticsearch.cli.SettingCommand.execute(SettingCommand.java:54) ~[elasticsearch-5.1.1.jar:5.1.1]
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:96) ~[elasticsearch-5.1.1.jar:5.1.1]
at org.elasticsearch.cli.Command.main(Command.java:62) ~[elasticsearch-5.1.1.jar:5.1.1]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:89) ~[elasticsearch-5.1.1.jar:5.1.1]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:82) ~[elasticsearch-5.1.1.jar:5.1.1]
Caused by: java.lang.IllegalArgumentException: unknown setting [repositories.hdfs.path] please check that any required plugins are installed, or check the breaking change s documentation for removed settings

(David Pilato) #2

This is a bug.

We should either remove that from the documentation https://www.elastic.co/guide/en/elasticsearch/plugins/current/repository-hdfs-config.html

Or add it to the code base.

Would you like to open an issue?


(David Pilato) #3

I opened this


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.