Settings Exception with repository-hdfs plugin

Can someone point out what's wrong with my configuration of the
repository-hdfs plugin in my elasticsearch.yml ? I'm using Elasticsearch
v1.3.4, repository-hdfs v2.0.2. The relevant part of elasticsearch.yml:

repositories
hdfs:
path: "/user/jce/archive"

I think I'm following the configuration documentation
at https://github.com/elastic/elasticsearch-hadoop/tree/2.0/repository-hdfs
but I'm seeing errors of:

- SettingsException[Failed to load settings from 

[file:/etc/elasticsearch/elasticsearch.yml]]
ElasticsearchParseException[malformed, expected settings to start with
'object', instead was [VALUE_STRING]]

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b1aeb6ee-697a-4bbb-b5f4-d501785cef1f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You probably have a syntax error (make sure you are using spaces and NOT tabs in your yml file). I just did a quick
check and it worked with the latest ES.
As inspiration you can try the configuration used within the test suite (checked every night) available here [1].
Additionally you can register the repository dynamically through the REST API as documented here [2]. This makes it easy
to check various settings and see what works and doesn't.

Hope this helps,

[1] https://github.com/elastic/elasticsearch-hadoop/blob/master/repository-hdfs/src/itest/resources/elasticsearch.yml
[2] http://www.elastic.co/guide/en/elasticsearch/reference/1.5/modules-snapshots.html

On 3/30/15 7:31 PM, Scott E Lundgren wrote:

Can someone point out what's wrong with my configuration of the repository-hdfs plugin in my elasticsearch.yml ? I'm
using Elasticsearch v1.3.4, repository-hdfs v2.0.2. The relevant part of elasticsearch.yml:

repositories
hdfs:
path: "/user/jce/archive"

I think I'm following the configuration documentation
at https://github.com/elastic/elasticsearch-hadoop/tree/2.0/repository-hdfs but I'm seeing errors of:

 - SettingsException[Failed to load settings from [file:/etc/elasticsearch/elasticsearch.yml]]

ElasticsearchParseException[malformed, expected settings to start with 'object', instead was [VALUE_STRING]]

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
elasticsearch+unsubscribe@googlegroups.com mailto:elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/b1aeb6ee-697a-4bbb-b5f4-d501785cef1f%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/b1aeb6ee-697a-4bbb-b5f4-d501785cef1f%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.

--
Costin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/551BCA7E.7060204%40gmail.com.
For more options, visit https://groups.google.com/d/optout.

Thank you for linking to the yml file in the master branch as an example. I did have spaces but I had forgotten a colon after repositories!

  • SL

On Apr 1, 2015, at 6:37 AM, Costin Leau costin.leau@gmail.com wrote:

You probably have a syntax error (make sure you are using spaces and NOT tabs in your yml file). I just did a quick check and it worked with the latest ES.
As inspiration you can try the configuration used within the test suite (checked every night) available here [1]. Additionally you can register the repository dynamically through the REST API as documented here [2]. This makes it easy to check various settings and see what works and doesn't.

Hope this helps,

[1] https://github.com/elastic/elasticsearch-hadoop/blob/master/repository-hdfs/src/itest/resources/elasticsearch.yml https://github.com/elastic/elasticsearch-hadoop/blob/master/repository-hdfs/src/itest/resources/elasticsearch.yml
[2] http://www.elastic.co/guide/en/elasticsearch/reference/1.5/modules-snapshots.html http://www.elastic.co/guide/en/elasticsearch/reference/1.5/modules-snapshots.html

On 3/30/15 7:31 PM, Scott E Lundgren wrote:

Can someone point out what's wrong with my configuration of the repository-hdfs plugin in my elasticsearch.yml ? I'm
using Elasticsearch v1.3.4, repository-hdfs v2.0.2. The relevant part of elasticsearch.yml:

repositories
hdfs:
path: "/user/jce/archive"

I think I'm following the configuration documentation
at https://github.com/elastic/elasticsearch-hadoop/tree/2.0/repository-hdfs but I'm seeing errors of:

- SettingsException[Failed to load settings from [file:/etc/elasticsearch/elasticsearch.yml]]

ElasticsearchParseException[malformed, expected settings to start with 'object', instead was [VALUE_STRING]]

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
elasticsearch+unsubscribe@googlegroups.com mailto:elasticsearch+unsubscribe@googlegroups.com <mailto:elasticsearch+unsubscribe@googlegroups.com mailto:elasticsearch+unsubscribe@googlegroups.com>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/b1aeb6ee-697a-4bbb-b5f4-d501785cef1f%40googlegroups.com https://groups.google.com/d/msgid/elasticsearch/b1aeb6ee-697a-4bbb-b5f4-d501785cef1f%40googlegroups.com
<https://groups.google.com/d/msgid/elasticsearch/b1aeb6ee-697a-4bbb-b5f4-d501785cef1f%40googlegroups.com?utm_medium=email&utm_source=footer https://groups.google.com/d/msgid/elasticsearch/b1aeb6ee-697a-4bbb-b5f4-d501785cef1f%40googlegroups.com?utm_medium=email&utm_source=footer>.
For more options, visit https://groups.google.com/d/optout https://groups.google.com/d/optout.

--
Costin

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/goTVSOtXuXQ/unsubscribe https://groups.google.com/d/topic/elasticsearch/goTVSOtXuXQ/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com mailto:elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/551BCA7E.7060204%40gmail.com https://groups.google.com/d/msgid/elasticsearch/551BCA7E.7060204%40gmail.com.
For more options, visit https://groups.google.com/d/optout https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/F8E6B900-D6A2-4150-9C82-45522C9BA416%40scottelundgren.com.
For more options, visit https://groups.google.com/d/optout.