Config packetbeat for graylog error

hi, guys
i install packetbeat version 7.4.2 (amd64), on linux centOS 7
but with error The following was encountered
*//
[root@webgateway ~]# packetbeat test output
elasticsearch: http://192.100.102.25:9200...
parse url... OK
connection...
parse host... OK
dns lookup... OK
addresses: 192.100.102.25
dial up... OK
TLS... WARN secure connection disabled
talk to server... ERROR Connection marked as failed because the onConnect callback failed: packetbeat requires the default distribution of Elasticsearch. Please update to the default distribution of Elasticsearch for full access to all free features, or switch to the OSS distribution of packetbeat.

please guide me
:pray:

It is exactly what the error message says. It looks like you are running the OSS distribution of Elasticsearch. This default distribution of Packetbeat requires the default distribution of Elasticsearch, not OSS, so you either need to upgrade Elasticsearch or change to the OSS distribution of Packetbeat.

1 Like

hi
thanks for answering
OK ,
I change yumll file ['vim /etc/packetbeat/packetbeat.yml'] ip and port in logstash output
and restart service packetbeat
It works now.
// [root@centos_graylog ~]# packetbeat test config
Config OK
[root@centos_graylog ~]# packetbeat test output
logstash: 192.100.102.25:15999...
connection...
parse host... OK
dns lookup... OK
addresses: 192.100.102.25
dial up... OK
TLS... WARN secure connection disabled
talk to server... OK
[root@centos_graylog ~]#
//

Thanks for your good guidance :slightly_smiling_face: