Configuring cross-cloud cluster via REST API


(Martin Harris) #1

Hi Folks,

I'm trying to setup a cross-cloud elastic-search cluster. As it's
cross-cloud, the usual discovery will not work, so I've started
elasticsearch on three nodes with multicast disabled
(discovery.zen.ping.multicast.enabled=false) and unicast enabled
(discovery.zen.ping.multicast.enabled=false). I then try to enable the
cluster by running the following against one (or all) of the nodes:

curl -XPUT http://localhost:9200/_cluster/settings -d '{ "persistent" : {
"discovery.zen.ping.unicast.hosts":"37.58.110.34:9200,37.58.110.35:9200,37.58.110.36:9200"}}'

The curl commands returns the following:

{"acknowledged":true,"persistent":{},"transient":{}}

But when I check the status of the cluster with the following:

curl http://localhost:9200/_cluster/settings

The curl command returns this:

{"acknowledged":true,"persistent":{},"transient":{}}{"acknowledged":true,"persistent":{},"transient":{}}

And the cluster has not been initialized

The following is also added to the log:

[WARN ][action.admin.cluster.settings] [elasticsearch-1] ignoring transient
setting [discovery.zen.ping.unicast.hosts], not dynamically updateable

Any help would be appreciated

Cheers

Martin Harris

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ee89982f-0bc3-456b-a9e4-2a06a0b6b0c6%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Itamar Syn-Hershko) #2

This will not work, discovery is done on port 9300 (by default) and cannot
be done over HTTP

I think what you are looking for is tribe node -
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-tribe.html

You'll then have 2 separate clusters but you can talk to both as one

--

Itamar Syn-Hershko
http://code972.com | @synhershko https://twitter.com/synhershko
Freelance Developer & Consultant
Author of RavenDB in Action http://manning.com/synhershko/

On Mon, Jun 2, 2014 at 1:49 PM, Martin Harris <
martin.harris@cloudsoftcorp.com> wrote:

Hi Folks,

I'm trying to setup a cross-cloud elastic-search cluster. As it's
cross-cloud, the usual discovery will not work, so I've started
elasticsearch on three nodes with multicast disabled
(discovery.zen.ping.multicast.enabled=false) and unicast enabled
(discovery.zen.ping.multicast.enabled=false). I then try to enable the
cluster by running the following against one (or all) of the nodes:

curl -XPUT http://localhost:9200/_cluster/settings -d '{ "persistent" : {
"discovery.zen.ping.unicast.hosts":"37.58.110.34:9200,37.58.110.35:9200,
37.58.110.36:9200"}}'

The curl commands returns the following:

{"acknowledged":true,"persistent":{},"transient":{}}

But when I check the status of the cluster with the following:

curl http://localhost:9200/_cluster/settings

The curl command returns this:

{"acknowledged":true,"persistent":{},"transient":{}}{"acknowledged":true,"persistent":{},"transient":{}}

And the cluster has not been initialized

The following is also added to the log:

[WARN ][action.admin.cluster.settings] [elasticsearch-1] ignoring
transient setting [discovery.zen.ping.unicast.hosts], not dynamically
updateable

Any help would be appreciated

Cheers

Martin Harris

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/ee89982f-0bc3-456b-a9e4-2a06a0b6b0c6%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/ee89982f-0bc3-456b-a9e4-2a06a0b6b0c6%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAHTr4Ztc%2BvBDrZt3ApVD%2B%3DCeH-ODh2J%2BtHVFDdyTK3vcsDSoVQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Martin Harris) #3

Thanks Itamar,

The tribe setup might work, but it may be easier if I can (at runtime)
simply give elasticsearch a new IP address to add to the cluster - this
will be accessible on port 9300 so the communication will not be over HTTP.
Is there any way to do this?

Cheers

Martin

On 2 June 2014 11:57, Itamar Syn-Hershko itamar@code972.com wrote:

This will not work, discovery is done on port 9300 (by default) and cannot
be done over HTTP

I think what you are looking for is tribe node -
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-tribe.html

You'll then have 2 separate clusters but you can talk to both as one

--

Itamar Syn-Hershko
http://code972.com | @synhershko https://twitter.com/synhershko
Freelance Developer & Consultant
Author of RavenDB in Action http://manning.com/synhershko/

On Mon, Jun 2, 2014 at 1:49 PM, Martin Harris <
martin.harris@cloudsoftcorp.com> wrote:

Hi Folks,

I'm trying to setup a cross-cloud elastic-search cluster. As it's
cross-cloud, the usual discovery will not work, so I've started
elasticsearch on three nodes with multicast disabled
(discovery.zen.ping.multicast.enabled=false) and unicast enabled
(discovery.zen.ping.multicast.enabled=false). I then try to enable the
cluster by running the following against one (or all) of the nodes:

curl -XPUT http://localhost:9200/_cluster/settings -d '{ "persistent" :
{ "discovery.zen.ping.unicast.hosts":"37.58.110.34:9200,37.58.110.35:9200
,37.58.110.36:9200"}}'

The curl commands returns the following:

{"acknowledged":true,"persistent":{},"transient":{}}

But when I check the status of the cluster with the following:

curl http://localhost:9200/_cluster/settings

The curl command returns this:

{"acknowledged":true,"persistent":{},"transient":{}}{"acknowledged":true,"persistent":{},"transient":{}}

And the cluster has not been initialized

The following is also added to the log:

[WARN ][action.admin.cluster.settings] [elasticsearch-1] ignoring
transient setting [discovery.zen.ping.unicast.hosts], not dynamically
updateable

Any help would be appreciated

Cheers

Martin Harris

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/ee89982f-0bc3-456b-a9e4-2a06a0b6b0c6%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/ee89982f-0bc3-456b-a9e4-2a06a0b6b0c6%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/CIJ3h7Tpzt4/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAHTr4Ztc%2BvBDrZt3ApVD%2B%3DCeH-ODh2J%2BtHVFDdyTK3vcsDSoVQ%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAHTr4Ztc%2BvBDrZt3ApVD%2B%3DCeH-ODh2J%2BtHVFDdyTK3vcsDSoVQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
Martin Harris
Lead Software Engineer
Cloudsoft Corporation Ltd


Mobile: +44 (0)7989 047-855

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEzXC-FU%2BePPU03sGjyCJmgOarL_N%2BdQpSD4nJtiyj8V5y5opw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Jörg Prante) #4

You have to restart the whole cluster. Switching discovery while running a
cluster is not possible.

Jörg

On Mon, Jun 2, 2014 at 12:49 PM, Martin Harris <
martin.harris@cloudsoftcorp.com> wrote:

Hi Folks,

I'm trying to setup a cross-cloud elastic-search cluster. As it's
cross-cloud, the usual discovery will not work, so I've started
elasticsearch on three nodes with multicast disabled
(discovery.zen.ping.multicast.enabled=false) and unicast enabled
(discovery.zen.ping.multicast.enabled=false). I then try to enable the
cluster by running the following against one (or all) of the nodes:

curl -XPUT http://localhost:9200/_cluster/settings -d '{ "persistent" : {
"discovery.zen.ping.unicast.hosts":"37.58.110.34:9200,37.58.110.35:9200,
37.58.110.36:9200"}}'

The curl commands returns the following:

{"acknowledged":true,"persistent":{},"transient":{}}

But when I check the status of the cluster with the following:

curl http://localhost:9200/_cluster/settings

The curl command returns this:

{"acknowledged":true,"persistent":{},"transient":{}}{"acknowledged":true,"persistent":{},"transient":{}}

And the cluster has not been initialized

The following is also added to the log:

[WARN ][action.admin.cluster.settings] [elasticsearch-1] ignoring
transient setting [discovery.zen.ping.unicast.hosts], not dynamically
updateable

Any help would be appreciated

Cheers

Martin Harris

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/ee89982f-0bc3-456b-a9e4-2a06a0b6b0c6%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/ee89982f-0bc3-456b-a9e4-2a06a0b6b0c6%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoHpxKv_PGYN1DuDjSRSFHAJn_4ktHDiZ3v5x9Wyry1q7g%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Itamar Syn-Hershko) #5

Just enable multicast using the plugin for your cloud provider...

--

Itamar Syn-Hershko
http://code972.com | @synhershko https://twitter.com/synhershko
Freelance Developer & Consultant
Author of RavenDB in Action http://manning.com/synhershko/

On Mon, Jun 2, 2014 at 2:08 PM, Martin Harris <
martin.harris@cloudsoftcorp.com> wrote:

Thanks Itamar,

The tribe setup might work, but it may be easier if I can (at runtime)
simply give elasticsearch a new IP address to add to the cluster - this
will be accessible on port 9300 so the communication will not be over HTTP.
Is there any way to do this?

Cheers

Martin

On 2 June 2014 11:57, Itamar Syn-Hershko itamar@code972.com wrote:

This will not work, discovery is done on port 9300 (by default) and
cannot be done over HTTP

I think what you are looking for is tribe node -
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-tribe.html

You'll then have 2 separate clusters but you can talk to both as one

--

Itamar Syn-Hershko
http://code972.com | @synhershko https://twitter.com/synhershko
Freelance Developer & Consultant
Author of RavenDB in Action http://manning.com/synhershko/

On Mon, Jun 2, 2014 at 1:49 PM, Martin Harris <
martin.harris@cloudsoftcorp.com> wrote:

Hi Folks,

I'm trying to setup a cross-cloud elastic-search cluster. As it's
cross-cloud, the usual discovery will not work, so I've started
elasticsearch on three nodes with multicast disabled
(discovery.zen.ping.multicast.enabled=false) and unicast enabled
(discovery.zen.ping.multicast.enabled=false). I then try to enable the
cluster by running the following against one (or all) of the nodes:

curl -XPUT http://localhost:9200/_cluster/settings -d '{ "persistent" :
{ "discovery.zen.ping.unicast.hosts":"37.58.110.34:9200,
37.58.110.35:9200,37.58.110.36:9200"}}'

The curl commands returns the following:

{"acknowledged":true,"persistent":{},"transient":{}}

But when I check the status of the cluster with the following:

curl http://localhost:9200/_cluster/settings

The curl command returns this:

{"acknowledged":true,"persistent":{},"transient":{}}{"acknowledged":true,"persistent":{},"transient":{}}

And the cluster has not been initialized

The following is also added to the log:

[WARN ][action.admin.cluster.settings] [elasticsearch-1] ignoring
transient setting [discovery.zen.ping.unicast.hosts], not dynamically
updateable

Any help would be appreciated

Cheers

Martin Harris

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/ee89982f-0bc3-456b-a9e4-2a06a0b6b0c6%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/ee89982f-0bc3-456b-a9e4-2a06a0b6b0c6%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/CIJ3h7Tpzt4/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAHTr4Ztc%2BvBDrZt3ApVD%2B%3DCeH-ODh2J%2BtHVFDdyTK3vcsDSoVQ%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAHTr4Ztc%2BvBDrZt3ApVD%2B%3DCeH-ODh2J%2BtHVFDdyTK3vcsDSoVQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
Martin Harris
Lead Software Engineer
Cloudsoft Corporation Ltd
www.cloudsoftcorp.com
Mobile: +44 (0)7989 047-855

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAEzXC-FU%2BePPU03sGjyCJmgOarL_N%2BdQpSD4nJtiyj8V5y5opw%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAEzXC-FU%2BePPU03sGjyCJmgOarL_N%2BdQpSD4nJtiyj8V5y5opw%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAHTr4Zsx%2B%2BbHEjHMRML91C7u83hcJfzczpkvZCs%2BLe5BU7bGFw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #6