Coordina map zoom limitation -- how get full zoom 21/22


(Ed B) #1

I created a real world model of a building and host it on my own geoserver. I noticed that I can't achieve the maximum zoom 21 or 22 which translates to about 1:133 scale.
However Kibana I guess may go maybe to zoom 17 (guess) , which makes the objact rather tiny. How do I overcome this limitation?


(Jon Budzenski) #2

Can you share which settings you have configured? tilemap.options.maxZoom in kibana.yml may be what you're looking for, ref.


(Ed B) #3

Not sure if I understood your question correctly:
Check the GeoServer URL at the end to see how it should look like.

Is there a way to NOT use Geohash, but rather directly visualize the location points?

In the data tab:
Buckets

  • Geo Coordinates
    • Geohash

Field
-location (from my mapping)
Precission 7

unclicked Change precision on map zoom
clicked Plasce marjers off grid
clicked Only request data around extend of map

Options:
clicked Desaturate map tiless
clicked WMS compliant map server:
WMS url*
http://50.116.4.250:8080/geoserver/DH_mid/wms
WMS layers*
test123_dxf_Polyline

mapping:
{
"apc_latlong5" : {
"mappings" : {
"temp1" : {
"properties" : {
"IP" : {
"type" : "ip"
},
"UTC_time" : {
"type" : "date"
},
"date_now" : {
"type" : "date"
},
"humidExt" : {
"type" : "half_float"
},
"local_time" : {
"type" : "short"
},
"location" : {
"type" : "geo_point",
"ignore_malformed" : true
},
"tempExt1" : {
"type" : "half_float"
}
}
}
}
}
}

GEOSERVER URL:
http://50.116.4.250:8080/geoserver/DH_mid/wms?service=WMS&version=1.1.0&request=GetMap&layers=DH_mid:test123_dxf_Polyline&styles=&bbox=-90.61287367345577,43.65194566600095,-90.61272032084199,43.652044555335735&width=768&height=495&srs=EPSG:404000&format=application/openlayers#toggle


(Ed B) #4

Adde to my kibana.yml just the bolow line, but it did NOT help. Do I need to add anything else?

tilemap.options.maxZoom: 21


(Ed B) #5


(Ed B) #6

After reading posts on Elastic Github I experimented to see if a licence could be a chalange here.

Same issue still persists with trial and basic licences. Cant zoom past the 1:1000 scale.

Any recommendations?


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.