Copy as cURL is gray out

I upgraded to 7.15 and I can't use copy as cURL in kabana

How do I get that back.. using Google chrome as browser if it helps

It was working fine on 7.12

This usually happens in non-secure contexts (e.g. if there is no https connection). Can you check that you are have a secure connection?

I don't use secure connection. when did it got change? it worked in 7.12. must be after that. whyyyy?

I think that it changed on 7.13 according to the release notes.

This is the change, Copy as Curl now uses the browser Clipboard API which only works on secured sites.

From the github tags it was also backported to 7.12.2, so 7.12.1 should be the last version where you can use copy as curl without https.

1 Like

ohh man. ok. I guess nothing I can do. that was very very useful tool.

You just need to use a SSL certificate in Kibana to use it with HTTPS and the feature will work again.

1 Like

yes but that means I have to secure all my other traffic and lot more it is not as simple as putting ssl in to kibana.

It really depends, if you are using unsecured communications in your cluster and between Elasticsearch and kibana, you can secure the communication between kibana and your browser without changing the other communications, it is a different setting.

You can have an unsecured cluster and use Kibana with HTTPS if you want.

ohhh I didn't know that.

ok I use basic authentication for Elasticsearch, space and stuff. has created p12 certificate.

but if I can use only https from kibana then it is prefect. can you point me to some setup document on how do I do it?

You can read this part of the documentation.

It explain how to secure communications between Kibana and the browser.

1 Like

ok. I follow that documentation

created .key and .csr
send that .csr to internal CA for signing. they send me file with .cer

here is my config looks like

https setup test

server.ssl.enable: true
server.ssl.certificate: /etc/kibana/config/certnew.cer
server.ssl.key: /etc/kibana/config/houelkdev01.key

and here are the erros

[2021-10-19T14:10:31.540-05:00][FATAL][root] Error: [config validation of [server].ssl.enable]: definition for this key is missing
    at ObjectType.validate (/usr/share/kibana/node_modules/@kbn/config-schema/target_node/types/type.js:88:13)
    at ConfigService.validateAtPath (/usr/share/kibana/node_modules/@kbn/config/target_node/config_service.js:232:19)
    at MapSubscriber.project (/usr/share/kibana/node_modules/@kbn/config/target_node/config_service.js:240:169)
    at MapSubscriber._next (/usr/share/kibana/node_modules/rxjs/internal/operators/map.js:49:35)
    at (/usr/share/kibana/node_modules/rxjs/internal/Subscriber.js:66:18)
    at DistinctUntilChangedSubscriber._next (/usr/share/kibana/node_modules/rxjs/internal/operators/distinctUntilChanged.js:69:30)
    at (/usr/share/kibana/node_modules/rxjs/internal/Subscriber.js:66:18)
    at MapSubscriber._next (/usr/share/kibana/node_modules/rxjs/internal/operators/map.js:55:26)
    at (/usr/share/kibana/node_modules/rxjs/internal/Subscriber.js:66:18)
    at ReplaySubject._subscribe (/usr/share/kibana/node_modules/rxjs/internal/ReplaySubject.js:80:28)

This is wrong, it is server.ssl.enabled not server.ssl.enable.

1 Like

I can't say enough Thank you Leandro. :pray: :pray: :pray:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.