Could not locate that index-pattern (id: api-filebeat-*)

Hello,

I am loading Filebeat pre-built dashboards into Kibana using the command

filebeat setup -e --dashboards

and having the following filebeat.yml configuration concerning indices:

setup.dashboards.enabled: true
setup.dashboards.index: "api-filebeat-*"
setup.dashboards.kibana_index: ".kibana_1"
setup.kibana.host: "https://***:443"
setup.kibana.username: ***
setup.kibana.password: ***

setup.template.settings:
  index.number_of_shards: 1
setup.ilm.enabled: true
setup.ilm.policy_name: "api-filebeat"
setup.ilm.rollover_alias: "api-filebeat-%{[agent.version]}"
setup.ilm.pattern: "{now/d}-000001"

The issue is that even though I have a api-filebeat-* pattern, I still get the following message in the dashboard visualizations:
Could not locate that index-pattern (id: api-filebeat-*), [click here to re-create it](#/management/kibana/index_pattern).

When I hit the .kibana index, I can see the pattern:

{
        "_index" : ".kibana_1",
        "_type" : "_doc",
        "_id" : "index-pattern:9aed3b50-93df-11ea-b566-290f21fe075f",
        "_score" : 1.0300813,
        "_source" : {
          "migrationVersion" : {
            "index-pattern" : "7.6.0"
          },
          "index-pattern" : {
            "timeFieldName" : "@timestamp",
            "title" : "api-filebeat-*"
          },
          "references" : [ ],
          "updated_at" : "2020-05-12T19:41:17.645Z",
          "type" : "index-pattern"
        }
}

I have seen some similar posts but they were pretty old and I could not solve my issue.

Elasticsearch: 7.6.2
Kiabana: 7.6.2
Filebeat: 7.6.2

Thanks for your help,
Mathieu

I also see that when running this command, an index pattern filebeat-* is created. But when looking at it in Kibana, I get errors Not found for its fields. I delete it.

Hi there Mathieu!

I'm not a filebeat expert, but it appears that the Dashboard is looking for an index-pattern with the id of api-filebeat-* while the index pattern that exists has an id of 9aed3b50-93df-11ea-b566-290f21fe075f. Since you already have an index pattern set up manually, I think you can change the setup.dashboards.index config to 9aed3b50-93df-11ea-b566-290f21fe075f and run filebeat setup -e --dashboards again.

Let me know if this works for you!

Hi Josh,

Thank you for your answer!
I did it the other way and created a new index pattern having id api-filebeat-*. Worked like a charm!

Thanks for your help,
Mathieu