Couldn't Activate Monitoring in 6.3


(Michael) #1

Following a 6.1 to 6.3 upgrade, monitoring within Kibana now shows an error message:

"We couldn't activate monitoring"

I've added the following two lines to my Elasticsearch.yml:

xpack.monitoring.enabled: true
xpack.monitoring.collection.enabled: true

The only error I'm seeing is in the kibana.stderr file and seems to indicate an index is read only?

Unhandled rejection [export_exception] Exception when closing export bulk :: {"path":"/_xpack/monitoring/_bulk","query":{"system_id":"kibana","system_api_version":"6","interval":"10000ms"},"body":"{"index":{"_type":"kibana_stats"}}\n{"concurrent_connections":4,"os":{"load":{"1m":2.81982421875,"5m":3.24560546875,"15m":3.23291015625},"memory":{"total_in_bytes":16827301888,"free_in_bytes":309764096,"used_in_bytes":16517537792},"uptime_in_millis":221157000},"process":{"event_loop_delay":0.6243259906768799,"memory":{"heap":{"total_in_bytes":135954432,"used_in_bytes":121463192,"size_limit":1501560832},"resident_set_size_in_bytes":199553024},"uptime_in_millis":6913806},"requests":{"disconnects":0,"total":1,"status_codes":{"200":1}},"response_times":{"average":59,"max":59},"timestamp":"2018-06-15T19:05:20.902Z","kibana":{"uuid":"f55b4301-cc59-4b64-b543-b766a36668c8","name":"redacted","index":".kibana","host":"redacted","transport_address":"0.0.0.0:5601","version":"6.3.0","snapshot":false,"status":"green"},"usage":{"index":".kibana","dashboard":{"total":9},"visualization":{"total":83},"search":{"total":1},"index_pattern":{"total":8},"graph_workspace":{"total":0},"timelion_sheet":{"total":0},"xpack":{"reporting":{"available":true,"enabled":true,"browser_type":"phantom","_all":0,"csv":{"available":true,"total":0},"printable_pdf":{"available":true,"total":0,"app":{"visualization":0,"dashboard":0},"layout":{"print":0,"preserve_layout":0}},"status":{},"lastDay":{"_all":0,"csv":{"available":true,"total":0},"printable_pdf":{"available":true,"total":0,"app":{"visualization":0,"dashboard":0},"layout":{"print":0,"preserve_layout":0}},"status":{}},"last7Days":{"_all":0,"csv":{"available":true,"total":0},"printable_pdf":{"available":true,"total":0,"app":{"visualization":0,"dashboard":0},"layout":{"print":0,"preserve_layout":0}},"status":{}}}}}}\n","statusCode":500,"response":"{"took":3,"ignored":false,"errors":true,"error":{"type":"export_exception","reason":"Exception when closing export bulk","caused_by":{"type":"export_exception","reason":"failed to flush export bulks","caused_by":{"type":"export_exception","reason":"bulk [default_local] reports failures when exporting documents","exceptions":[{"type":"export_exception","reason":"ClusterBlockException[blocked by: [FORBIDDEN/12/index read-only / allow delete (api)];]","caused_by":{"type":"cluster_block_exception","reason":"blocked by: [FORBIDDEN/12/index read-only / allow delete (api)];"}}]}}}}"}

Has anyone else run into this issue?


(Michael) #2

OK, self healed it... But for anyone else searching this error, refer to this thread:

In short, due to some space issue, it appears the indices were put into read only mode. My Kibana index was set as such so this console command fixed it:

PUT your_index_name/_settings
{
"index": {
"blocks": {
"read_only_allow_delete": "false"
}
}
}

Other indices may also be in that state so I'll check.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.