Enabling monitoring on v6.6

Hi, we've just upgraded to Elastic Stack v6.6 and tried to enable monitoring (we didn't have it enabled before).

I've set the following parameters in elasticsearch.yml:

xpack.monitoring.enabled: true
xpack.monitoring.collection.enabled: true
xpack.monitoring.elasticsearch.collection.enabled: true


xpack.monitoring.enabled: true
xpack.monitoring.kibana.collection.enabled: true
xpack.monitoring.ui.container.elasticsearch.enabled: true


xpack.monitoring.enabled: true
xpack.monitoring.elasticsearch.url: ["elasticsearch:9200"]

When going on the Monitoring tab in Kibana I get the following error:

When pressing the button I get the following error:

Upon checking the _cluster/settings endpoint I get the following:

"persistent": {
"archived": {
"xpack": {
"monitoring": {
"collection": {
"enabled": "true"
"transient": {

And I can't run the PUT request on the elastic guides on enabling monitoring because it gives me basically the same error that Kibana does.

Have I gone wrong somewhere or have things broken on the new release?

What version did you come from?

Version 6.5.4, I believe.

I've restarted the containers before anyone asks :slight_smile:

Then you shouldn't need to do anything, as of 6.3 it would have been enabled by default (other than in Logstash).

If you previously disabled it then that's a different discussion. Do you know if and why it was disabled?

It was disabled in Logstash previously.

I haven't changed any of the other settings from false to true, just added them to the file. It still requires some settings changing to get it working on 6.3 onwards, so that its visible on the Kibana UI, though?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.