XPack Monitoring Issue

In Kibana when i try to enable to monitoring i am getting the following error

" We checked the cluster defaults settings and found that xpack.monitoring.enabled is set to false set, which disables monitoring. Removing the xpack.monitoring.enabled: false setting from your configuration will put the default into effect and enable Monitoring."

However when i get the cluster settings i am seeing that xpack is enabled

{ "persistent" : { "xpack" : { "monitoring" : { "elasticsearch" : { "collection" : { "enabled" : "true" } }, "collection" : { "enabled" : "true" } } } }, "transient" : { } }

Hi, which version of Kibana do you have?

Do you have more than 1 cluster (e.g. a separate monitoring cluster)?

thanks for replying, the problem was due to the space issues. Cluster went to read only after it ran out of space. is there a way to delete indices older than number of days via kibana ? which we can use to avoid the space issues.

In Kibana there is index management: Index management | Kibana Guide [7.15] | Elastic

If you are looking for a more automated solution, there is an API in Elasticsearch called Index Lifecycle Management: ILM: Manage the index lifecycle | Elasticsearch Guide [7.15] | Elastic

I hope that helps!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.