How can i stop to generating monitoring index? its taking too much memory without any index creation

Hi i m using Elasticsearch 7.4
i just install and setup Elasticsearch and configure network.host & discovery.seed_hosts Parameter in /etc/elasticsearch/elasticsearch.yml file.
Now, when i am seeing in kibana , it showing 0 manual index ( which is true as i haven't created any index yet ) but showing 7 system indexes with 2L + documents.
can someone please help me over here ?
what is benefits of this monitoring indexes ?
can we stop it to be automatically generation ? if yes then how ? because xpack.monitoring.collection.enabled : true is not working in elasticsearch.yml file.

Also, in Kibana it showing only 1GB of Disk space available among 8GB.
what does it mean ?? while using htop command in linux terminal it's showing 2GB in use from 8GB so confusing over here.

Please advise

Did you try to set xpack.monitoring.collection.enabled: false in cluster setting? I'm not familiar with this part, @shaunak could you help us here please? :slightly_smiling_face:

@Kaiyan_Sheng is on the right track here.

@Mitesh_Shah1, could you please run the following API call from Kibana > Dev Tools > Console and post the output here?

GET _cluster/settings?include_defaults=true&filter_path=**.xpack.monitoring
1 Like

@shaunak
{
"persistent" : {
"xpack" : {
"monitoring" : {
"collection" : {
"enabled" : "true"
}
}
}
},
"defaults" : {
"xpack" : {
"monitoring" : {
"collection" : {
"cluster" : {
"stats" : {
"timeout" : "10s"
}
},
"node" : {
"stats" : {
"timeout" : "10s"
}
},
"indices" : ,
"ccr" : {
"stats" : {
"timeout" : "10s"
}
},
"index" : {
"stats" : {
"timeout" : "10s"
},
"recovery" : {
"active_only" : "false",
"timeout" : "10s"
}
},
"interval" : "10s",
"ml" : {
"job" : {
"stats" : {
"timeout" : "10s"
}
}
}
},
"history" : {
"duration" : "168h"
},
"elasticsearch" : {
"collection" : {
"enabled" : "true"
}
},
"enabled" : "true"
}
}
}
}

after running API call you given, it shows above output.

I already did, xpack.monitoring.collection.enabled: false this in elasticsearch.yml

Try issuing this API call:

PUT _cluster/settings
{
    "persistent": {
        "xpack.monitoring.collection.enabled": false
    }
}

Then call:

DELETE .monitoring*

That should delete your existing monitoring indices and not create new ones. You can check this by waiting for a minute or so and then calling:

GET _cat/indices/.monitoring*

You should not see any indices in the response.

Shaunak