Create custom filebeat module issue

Hi
I have problem with creating custom module, when I try to create module by comman make create-module MODULE=nameofModule, then I got Unknown targets specified: create-module, MODULE=name.

I folllowing by instructions and also this.

When I run make updatethen I got:

Added functools32==3.2.3.post2 from https://files.pythonhosted.org/packages/c5/60/6ac26ad05857c601308d8fb9e87fa36d0ebf889423f47c3502ef034365db/functools32-3.2.3-2.tar.gz#sha256=f6253dfbe0538ad2e387bd8fdfd9293c925d63553f5813c4e587745416501e6d (from -r C:(...)\go\src\github.com\elastic\beats/libbeat/tests/system/requirements.txt (line 13)) to build tracker 'C:\(...)\AppData\Local\Temp\pip-req-tracker-ws3wgda4'
2019-09-10T15:45:54,645 Running setup.py (path:...\AppData\Local\Temp\pip-install-0hx4zhq9\functools32\setup.py) egg_info for package functools32
2019-09-10T15:45:54,645 Running command python setup.py egg_info
2019-09-10T15:45:54,878 This backport is for Python 2.7 only.

If I should provide more information please let me know.

I wonder if this is an issue with the windows shell. Can you try running make create-module without the env variable and see if you get farther?

Thanks for reply :slight_smile:
You mean run only this command: make create-module? If yes, it not helped.

I try also on consoles which emulate linux environment, but unfortunately with the same result.