Create multi nodes on a single cluster into ES 2.0


(ciro) #1

Hi, is possible to create and starts multi nodes on a single cluster into ES 2.0?
I've tried the common config and some console commands but both don't work.
I known that some console commands are disabled but i can't create a second node on my server.

Someone can help me???


Multiple ES on one node
(Isabel Drost-Fromm) #2

Is there a typo in there - from what you write below it looks like you want to start multiple nodes on a single server?

Without knowing what exactly you did it's hard to guess what went wrong.

If you are indeed trying to run multiple ES nodes on one server the following instructions might help you:

Hope this helps,
Isabel


(ciro) #3

yes, i talk about to start two nodes in one Server.

i have created two config file but if i try to start both with this command:

bin/elasticsearch -Des.config=$ES_HOME/config/elasticsearch.1.yml

don't work.

I've read that -Des command is now disabled in the ES 2.0, maybe this is wrong.


(David Pilato) #4

es.config has been removed. You can use es.path.conf instead.

The dir you will declare there needs to have an elasticsearch.yml file.

So basically run:

bin/elasticsearch -Des.path.conf=$ES_HOME/config1
bin/elasticsearch -Des.path.conf=$ES_HOME/config2

Have a look at: https://www.elastic.co/guide/en/elasticsearch/reference/current/setup-dir-layout.html


(ciro) #5

Oh! i miss this modify... but if i try:

/usr/share/elasticsearch/bin/elasticsearch -Des.path.conf=/etc/elasticsearch/config1/elasticsearch.1.yml

i have this error:

Exception in thread "main" java.lang.RuntimeException: don't run elasticsearch as root.
at org.elasticsearch.bootstrap.Bootstrap.initializeNatives(Bootstrap.java:92)
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:138)
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:270)
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:35)

What i do wrong?


(David Pilato) #6

I think the message is really clear here:

don't run elasticsearch as root.

(ciro) #7

sorry, normally i run its as admin.....Thanks for the help!!!


(system) #8