Curator - Unable to run any commands


I just installed curator but I'm unable to run anything.

Curator ACTION_FILE.YML results in error no such command.

Other things I don't understand are:

  1. Version is listed as 5.4.0 but running --version I always get 3.4.1. I even tried the pip command with the specified version.

  2. No configuration file was present in home/user/.curator. Actually I didn't even have that folder after installation.

  3. I tried creating the folder and the config file manually (copy/pasted the config file from the docs) but that isn't working.

Tried installing on a different system and the same issue.

.deb shows 5.4.0 as version but after installation it jumps to Also no .curator folder created in the home folder. Locate doesn't find any folders or files named curator either.

  1. I think you'll find that if you uninstall it, that it's still installed as 3.4.1. You have multiple versions installed, and the system is finding 3.4.1 instead. Version 3.4.1 is in some of the core repositories out there.
  2. Curator does not automatically create a config file or config directory. You have to create those yourself.
  3. If the system finds 3.4.1 first in the system path, instead of 5.4.0, this is a likely outcome.


I don't know why but for some reason the next morning the version did show up as 5.4.0. After creating the config and action files I had no problems running curator.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.