Curl indices.memory.index_buffer_size?


(Chris Berry-2) #1

Hello,

I am trying to set indices.memory.index_buffer_size to 30% using curl to my
running cluster

And I am not able to make it "stick"
I am doing this:

$ curl -XPUT http://foo:9200/_cluster/settings -d '{ "persistent" : {
"indices.memory.index_buffer_size" : "30%" }}'
{"acknowledged":true,"persistent":{},"transient":{}

But when I check settings it is not there?

Any idea what I am doing wrong??
It is probably something obvious. But I don't see it...

Thanks,
-- Chris

$ curl -XGET http://foo:9200/_cluster/settings?pretty=true
{
"persistent" : {
"threadpool" : {
"index" : {
"type" : "cached"
}
}
},
"transient" : {
"cluster" : {
"routing" : {
"allocation" : {
"enable" : "all"
}
}
}
}
}

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0d6ca29a-3ecf-4050-85c8-f7672c4a964d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #2