How to set "indices.fielddata.cache.size" without setting in elasticsearch.yml


(Greg-4) #1

Hi,

i tried

curl -XPUT :/_cluster/settings -d '{
"persistent" : {
"indices.fielddata.cache.size": "20%"
}
}'

but it does not work: {"persistent":{},"transient":{}}

Thanks.

Greg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #2

This one is not listed on the updatable cluster settings here: http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/cluster-update-settings.html

So you can not update it live.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 20 novembre 2013 at 18:30:39, Greg (linuxzwerg@gmail.com) a écrit:

Hi,

i tried

curl -XPUT :/_cluster/settings -d '{
"persistent" : {
"indices.fielddata.cache.size": "20%"
}
}'

but it does not work: {"persistent":{},"transient":{}}

Thanks.

Greg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Greg-4) #3

Thanks!

Am Mittwoch, 20. November 2013 18:38:35 UTC+1 schrieb David Pilato:

This one is not listed on the updatable cluster settings here:
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/cluster-update-settings.html

So you can not update it live.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 20 novembre 2013 at 18:30:39, Greg (linux...@gmail.com <javascript:>)
a écrit:

Hi,

i tried

curl -XPUT :/_cluster/settings -d '{
"persistent" : {
"indices.fielddata.cache.size": "20%"
}
}'

but it does not work: {"persistent":{},"transient":{}}

Thanks.

Greg

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4