Custom Label field not available for MaxBucket aggregation

Whenever i am using "Max Bucket" sibling aggregation in "Metrics" section, i am not able to get custom field. The title is always something like " Overall Max of Count".
Using Kibana 7.7 . Please guide me how to get custom label for the same.

I think you have just hit a regression. Let me quickly ask the team in charge of Visualize and I will be back to you with a the issue to track on GH if any

any updates on that issue? I am facing a similar issue and I just found your answer and it must be a regression issue. I tested the same thing on Kibana 6.4.0 and there is a custom label field that doesn't exist on Kibana 7.7.1

It looks like the bug is reported and documented as a bug on github https://github.com/elastic/kibana/issues/69014
A quick workaround for me was to export the visualization, edit the ndjson file and add a customLabel like that \"customLabel\":\"fffff\",\"customMetric\":{\"enabled\":true,\ and import it again. This is not the best solution because you have to repeat the steps every time you want to modify the label.

As a temporary solution you are able to edit the json directly.

Stack Management > Saved objects > Edit visualization

inspect (three dots)

image

save

please note the warning: Modifying objects is for advanced users only...