Custom logs - Newly added log path not harvested

Fleet has been a saviour and a great tool to monitor server and logs easily. Thanks for making such an awesome product.

Have an existing custom logs integration and its harvesting files from a path and are being indexed correctly. Added another log path to the same integration, but the log entries on the files are neither indexed nor the log file name appears in the elastic-agent/ file-beat agent logs. Seems the new path is not being harvested.

We tried restarting the agent, re-adding the new log path, re enrolled the agent, reinstalled agent, waited for few days :slight_smile: , made sure the new path generates similar kind of log entries as the old working one (so ingest pipline is working). Still no luck :frowning:

We see a strange Out-of-date next to the agent policy. All intergrations are up-to-date.

api-server Healthy API rev. 57 Out-of-date 7.13.1 in 20 seconds

Can someone guide us in debugging this issue.

One of the field of the documents was mismatching with the existing index pattern field type. So document was not getting indexed.

@bravo, glad you managed to find the cause. Thanks for sharing the solution.