Custom transport port


I have an es cluster and I need to use custom transport path for various reasons. I have set transport.tcp.port: 19300:19400 on all nodes but the nodes cannot discover eachother.

Any help how to get it running?


I don't think Elasticsearch accepts a colon separating the port range. Did it throw an exception on start-up?

You need to define the nodes as unicast list.

Elasticsearch tries only to connect to ports from 9300-9399 if port is not set in unicast list.

Actually auto discovery is working with custom ports. It was firewall blocking the nodes from talking to eachother.

Thanks all for you help.

Oh? Really?

I guess all nodes are using the same range then???

Yes, all nodes using the same exact same range and we are also using the gce plugin for the autodiscovery.

Ha! So you changed es-port in GCE metadata then?

No, not touched any metadata on GCE, only thing I did I set up the transport.tcp.port: and http:port inside the elasticsearch configuration and modified the firewall settings on GCE to allow traffic on the configured ports. And added the gce related configuration in the elasticsearch.yml. Anything else worked out of the box if I can say that.