Dashboard Time Frame Not Affecting Pie Chart or Table Visualizations

How can I have the DatePicker on a Dashboard filter data in Pie Charts and Data Tables? Please view attached images. Example below:

There has been no data in the last 15 minutes, so this entire dashboard should be empty. The Timelion reflects no data which is correct (green checkmark) but the Pie Charts are not affected by the DatePicker at the top right corner.

Instead of showing data within the last 15 minutes, the Pie Charts are showing ALL DATA in the index. This is not want I want (red X's). As I said earlier, there has been no data within the last 15 minutes, so all of the Pie Charts should be empty as well.

DatePicker Not Affecting Pie Charts or Data Table Visualizations in Dashboard:

DatePicker QuickSelect exists on Timelion Visualization:
DatePicker QuickSelect on Timelion

No DatePicker on Pie Chart Visualization:
No DatePicker on Pie Chart

You have created your pie charts based on an index pattern that doesn't have a primary timefield. Because there's no primary timefield, the date picker is unable to know which time field to apply to your index.

If you want to set the primary timefield on your index pattern, the only option is to modify the saved index pattern using the Kibana API. You can look up the index-pattern object with your ID, and then set the timefieldName property which you appear not to have set.

Thanks! That was it. I just ended up recreating the index pattern and visualizations. I am in PoC phase with Kibana, so it wasn't too much work to recreate everything. I do not recommend doing this in Production though, for others who may come across this.