Date Histogram not showing Vertical bar chart


(Roopendra) #1

I am storing application build logs in an Elasticsearch index; Same index configured in Kibana as an index pattern for creating Visualization. I am able to search data on behalf of that index in Discover tab. Now when I am trying to create a Vertical Bar Chart visualization then its not showing a vertical bar chart.

In Vertical Bar chart I selected count for Y-Axis and Date Histogram interval monthly on the date field(buildDate) . Whereas data is available for Date Histogram [See 5 records is shown in table]. I have attached table value and bar chart here.

Data are not displaying in vertical bar chart.

Any suggestion ? Am I doing something wrong here?


(Peter Pisljar) #2

which version of kibana are you using ?
can you check browser console for any errors ?
I don't think you are doing anything wrong.


(Roopendra) #3

I am using Kibana Version: 5.1.1.

Getting below error message in JS console:

Error: this._attr is undefined
DataFactory/Data</<.value@http://127.0.0.1:5601/bundles/kibana.bundle.js?v=14566:44:31019
DataFactory/Data</<.value/<@http://127.0.0.1:5601/bundles/kibana.bundle.js?v=14566:44:31659
DataFactory/Data</<.value@http://127.0.0.1:5601/bundles/kibana.bundle.js?v=14566:44:31477
Data@http://127.0.0.1:5601/bundles/kibana.bundle.js?v=14566:44:24190
getData@http://127.0.0.1:5601/bundles/kibana.bundle.js?v=14566:46:16588
create/<@http://127.0.0.1:5601/bundles/kibana.bundle.js?v=14566:46:16818
VisFactory/Vis</<.value@http://127.0.0.1:5601/bundles/kibana.bundle.js?v=14566:54:25825
module.exports/VislibRenderbot.prototype.render/<@http://127.0.0.1:5601/bundles/kibana.bundle.js?v=14566:86:11376
processQueue@http://127.0.0.1:5601/bundles/commons.bundle.js?v=14566:38:23621
scheduleProcessQueue/<@http://127.0.0.1:5601/bundles/commons.bundle.js?v=14566:38:23888
$RootScopeProvider/this.$get</Scope.prototype.$eval@http://127.0.0.1:5601/bundles/commons.bundle.js?v=14566:39:4607
$RootScopeProvider/this.$get</Scope.prototype.$digest@http://127.0.0.1:5601/bundles/commons.bundle.js?v=14566:39:2343
$RootScopeProvider/this.$get</Scope.prototype.$apply@http://127.0.0.1:5601/bundles/commons.bundle.js?v=14566:39:5026
timeout/timeoutId<@http://127.0.0.1:5601/bundles/commons.bundle.js?v=14566:39:17601
completeOutstandingRequest@http://127.0.0.1:5601/bundles/commons.bundle.js?v=14566:36:4607
Browser/self.defer/timeoutId<@http://127.0.0.1:5601/bundles/commons.bundle.js?v=14566:36:7706

(Peter Pisljar) #4

Looks like a bug. Could you help me narrow it down ? Does it only happen when you select monthly interval ? have you tried other field, other index, other aggregation type ? Have you changed any options ?

thanks!


(Roopendra) #5

Thanks for your response.

This issue persists with all intervals.

Yes, I tried with other index, but the same set of data still facing the same issue.
It's working fine with other aggregation type.

The same issue with other fields.

No, I haven't change any option.


(Court Ewing) #6

This sounds like the issue described in https://github.com/elastic/kibana/issues/9572


(Roopendra) #7

Correct. This is the similar issue with Area Chart. I am linking this thread with the issue. Thanks.


(Court Ewing) #8

Great, this should be fixed in the next patch release (5.1.2) then.


(system) #9

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.