Defing default mapping to enable _timestamp for all indices


(kazoompa-3) #1

Hi,

I have the following ES setting defined in my YAML file:

http.enabled: false
discovery.zen.ping.multicast.enabled: false
index:
mappings:
default:
_timestamp:
enabled: true
store : true
analysis:
analyzer:
mica_index_analyzer:
type: custom
tokenizer: standard
filter: [standard,lowercase,mica_nGram_filter]
mica_search_analyzer:
type: custom
tokenizer: standard
filter: [standard,lowercase]
filter:
mica_nGram_filter:
type: nGram
min_gram: 2
max_gram: 20

My intention is to enable the _timestamp field for all created indices. The
above does not seem to work, is the error in the syntax of the YAML or I am
missing a step?

Thanks.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9bd349c6-a7f4-4627-af0e-088ffe2a0418%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #2