Deleted alias still causing conflict when restoring snapshot

Hi everyone,

I want to restore an indice from a snapshot with a certain name. It turned out that the same name was set as an alias for another index. So I deleted the alias, because I did not need it anymore.

Now, if I call

GET /_all/_alias

it does not list the alias anymore. But if I call _restore on my snapshot I still get a conflict message caused by the alias.

Does someone know what might be the problem here?

I am using Elasticsearch 7.4 and I am running the commands via Kibana Console.

I figured out that the alias must be deleted in the snapshot too. So saving a new snapshot without alias worked for me.

Hi @V.krae

This sounds like a potential bug to me. Were you unable to restore a snapshot that contained a certain alias even though you did not have an index or alias by that same name in your cluster?
I'm assuming you didn't as you said that you deleted the alias?

Hi,

yes I was unable to restore the snapshot eventhough I deleted everything with the same name and alias in my cluster.

But in the snapshot the index I wanted rename while restoring still had the same name as alias stored. I guess that caused the conflict since the index name was already included as alias.

So the name of the index would have been identical to the alias after restoring. I guess it does make sense that this case is causing a conflict.

Right, thanks for getting back to me and clarifying @V.krae :slight_smile: