Dependecy of logstash-filter-collate with old version of logstash-core-plugin-api


(Pierre Rebours) #1

Installing logstash-filter-collate fails:
logstash-plugin install --version 2.0.4 logstash-filter-collate

It seems that the plugin has a dependency on logstash-core-plugin-api (~> 1.0) while I have the following gem installed:
logstash-core-plugin-api (= 2.1.12)

The problem seems to be similar with another isssue (Logstash-filter-prune gem dependencies)

I would suggest to change the gemspec from:
s.add_runtime_dependency "logstash-core-plugin-api", "~> 1.0"
to
s.add_runtime_dependency 'logstash-core-plugin-api', '>= 1.60', '<= 2.99'

Is it the correct diagnostic?


(João Duarte) #2

This plugin needs to be updated to the new event api, the transition is quite simple, do you want to create a PR and I'll review and merge?


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.