Installing logstash-filter-collate fails:
logstash-plugin install --version 2.0.4 logstash-filter-collate
It seems that the plugin has a dependency on logstash-core-plugin-api (~> 1.0) while I have the following gem installed:
logstash-core-plugin-api (= 2.1.12)
The problem seems to be similar with another isssue (Logstash-filter-prune gem dependencies)
I would suggest to change the gemspec from:
s.add_runtime_dependency "logstash-core-plugin-api", "~> 1.0"
s.add_runtime_dependency 'logstash-core-plugin-api', '>= 1.60', '<= 2.99'
Is it the correct diagnostic?