Collate plugin installation fails


i am trying to install collate plugin with logstash version 5.1.1 on ubuntu 16.04

it gives me the following error can anyone please help me out with this

oot@SSP-Desk:/usr/share/logstash/bin# ./logstash-plugin install logstash-filter-collate
Validating logstash-filter-collate
Installing logstash-filter-collate
Plugin version conflict, aborting
ERROR: Installation Aborted, message: Bundler could not find compatible versions for gem "logstash-core-plugin-api":
In snapshot (Gemfile.lock):
logstash-core-plugin-api (= 2.1.12)

In Gemfile:
logstash-devutils (>= 0) java depends on
logstash-core-plugin-api (~> 2.0) java

The collate plugin hasn't been updated to the new event API and is therefore not compatible with Logstash 5.x and later.