Not able to install collate plugin


#1

Hi,

With 5.4.0 version of logstash I am not able to install collate plugin. I am getting below errors. Please help.

bin/logstash-plugin install logstash-filter-collate
Validating logstash-filter-collate
Installing logstash-filter-collate
Plugin version conflict, aborting
ERROR: Installation Aborted, message: Bundler could not find compatible versions for gem "logstash-core-plugin-api":
In snapshot (Gemfile.lock):
logstash-core-plugin-api (= 2.1.12)

In Gemfile:
logstash-devutils (>= 0) java depends on
logstash-core-plugin-api (<= 2.99, >= 2.0) java

logstash-input-s3 (>= 0) java depends on
  logstash-mixin-aws (>= 0) java depends on
    logstash-core-plugin-api (<= 2.99, >= 1.60) java

logstash-input-s3 (>= 0) java depends on
  logstash-mixin-aws (>= 0) java depends on
    logstash-core-plugin-api (<= 2.99, >= 1.60) java

logstash-input-s3 (>= 0) java depends on
  logstash-mixin-aws (>= 0) java depends on
    logstash-core-plugin-api (<= 2.99, >= 1.60) java

logstash-output-stdout (>= 0) java depends on
  logstash-core-plugin-api (< 2.99, >= 1.60.1) java

logstash-input-s3 (>= 0) java depends on
  logstash-mixin-aws (>= 0) java depends on
    logstash-core-plugin-api (<= 2.99, >= 1.60) java

logstash-input-s3 (>= 0) java depends on
  logstash-mixin-aws (>= 0) java depends on
    logstash-core-plugin-api (<= 2.99, >= 1.60) java

logstash-input-s3 (>= 0) java depends on
  logstash-mixin-aws (>= 0) java depends on
    logstash-core-plugin-api (<= 2.99, >= 1.60) java

logstash-filter-dissect (>= 0) java depends on
  logstash-core-plugin-api (<= 2.99, >= 2.1.1) java

logstash-input-s3 (>= 0) java depends on
  logstash-mixin-aws (>= 0) java depends on
    logstash-core-plugin-api (<= 2.99, >= 1.60) java

logstash-input-s3 (>= 0) java depends on
  logstash-mixin-aws (>= 0) java depends on
    logstash-core-plugin-api (<= 2.99, >= 1.60) java

logstash-input-s3 (>= 0) java depends on
  logstash-mixin-aws (>= 0) java depends on
    logstash-core-plugin-api (<= 2.99, >= 1.60) java

logstash-filter-collate (>= 0) java depends on
  logstash-core-plugin-api (~> 1.0) java

logstash-core-plugin-api (>= 0) java

Running bundle update will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.
Bundler could not find compatible versions for gem "logstash-core":
In snapshot (Gemfile.lock):
logstash-core (= 5.4.0)

In Gemfile:
logstash-core-plugin-api (>= 0) java depends on
logstash-core (= 5.4.0) java

logstash-filter-collate (>= 0) java depends on
  logstash-core (< 2.0.0, >= 1.4.0) java

logstash-core (>= 0) java

Running bundle update will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.
Bundler could not find compatible versions for gem "rufus-scheduler":
In snapshot (Gemfile.lock):
rufus-scheduler (= 3.0.9)

In Gemfile:
logstash-input-http_poller (>= 0) java depends on
rufus-scheduler (~> 3.0.9) java

logstash-input-jdbc (>= 0) java depends on
  rufus-scheduler (>= 0) java

logstash-input-http_poller (>= 0) java depends on
  rufus-scheduler (~> 3.0.9) java

logstash-filter-collate (>= 0) java depends on
  rufus-scheduler (~> 2.0.24) java

Running bundle update will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.


(Magnus B├Ąck) #2

That plugin hasn't been updated to be compatible with Logstash 5.x and later.


#3

Thanks for reply Megnus.

I tried with logstash-output-json_batch as well. Even that is not working with latest logstash.

Basically I want to batch multiple events and send it to http output.

Any alternative for these plugin in latest version of logstash? OR any work around to get this working?


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.