Different results in Discover and Dev Console

Hi,

I'm still confused when elaticsearch is the right tool to use. As a exercise I imported editions from the OpenLibrary and tried to do some searches. I wrote a mapping and tried to filter out any prvious unicode issues where 'München' has been set to 'Mu nchen'. So I have edition.publish_places as a keyword containing 'Mu nchen'. Using the dev console I get 722 hits with the following search:

GET /filebeat-7.16.3/_search
{
  "query": {
    "term": {
      "edition.publish_places.keyword": {
        "value": "Mu nchen"
      }
    }
  },
  "fields": [
    "_id",
    "edition.title.keyword",
    "edition.publish_places.keyword"
  ],
  "_source": false
}

Trying the same sing in discover gives me only one hit. Of course I set the timerange to max and filtered ' edition.publish_places: 'Mu nchen' (not KQL). I dont really understand why. I hoped I could use kibana to get the results out in a nice table like format but it seems very complicated. Can I somehow use the former query and then have the visualize library format it to a table?

Regards

btn

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.